Rough Acceleration & CEL with P1456
NEWS
 

  1. Welcome to Honda Odyssey Forum : Odyssey Minivan Forums General discussion forum for Honda Odyssey

    Welcome to Honda Odyssey Forum : Odyssey Minivan Forums - a website dedicated to all things Honda Odyssey.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Honda Odyssey Forum : Odyssey Minivan Forums today!
     
+ Reply to Thread
Results 1 to 8 of 8

Thread: Rough Acceleration & CEL with P1456

  1. #1
    Registered User
    Join Date
    Nov 2011
    Location
    California
    Posts
    17

    Rough Acceleration & CEL with P1456

    I purchased an Odyssey 2000 with 90K ... Although it has a very low mileage, it is very rough when accelerating ... When it is idealing, it is fine and on high speeds it runs OK but you feel that the engine is sounding rough ... I followed the process of cleaning the EGR valve path/port and it was not really that clogged ... Changed oil with OEM filter and 5-20w Honda Synthetic Blend ... Put a new OEM Air Filter ... Still rough ... Any advice really is appreciated ...

    The 2nd problem with my Odyssey is the Check Engine light with P1456 ... Again, changed the Fuel Tank Cap with OEM as recommended then changed the EVAP canister, reset the CEL but it went ON again after 30 miles ... Please advice me how can I troubleshoot this problem ... Thx.

  2. Remove Advertisements
    OdyClub.com
    Advertisements
     

  3. #2
    Registered User New Dad New Van's Avatar
    Join Date
    Dec 2003
    Location
    Canada
    Posts
    5,562
    Along with the EGR port cleaning you need to replace the EGR valve as well. Check the spark plugs. They are recommended to be changed at 105K miles with OEM NGK Platinums.

    The gas cap leaking is the most common for P1456. Next would be to locate a crack at the base of the fuel neck filler tube - where it meets the fuel tank. Also a leak around the intank fuel pump on the top of the fuel tank.
    2001 Odyssey LX
    2003 ACURA EL Touring

    UNOFFICIAL 2001 ODYSSEY THREAD: http://www.odyclub.com/forums/showth...664#post384664

  4. #3
    Registered User
    Join Date
    Oct 2006
    Location
    New Hampshire
    Posts
    1,392
    There's a post on here about taking apart the fuel filler neck and sealing it. That fixed my 1456 code, I haven't seen it in over a year. Just search the code and you'll find it with pictures. As for the roughness, does it feel like it's skipping? Maybe there's a bad coil that has yet to throw a code. Search coil and you'll see how to check that by unplugging one at a time. When my EGR needed cleaning it did not affect acceleration but surged when maintaining 45 on a flat road. Please post back with what you find.
    Mike
    2000 Odyssey LX
    Trans at 82k -- Tru-cool trans cooler
    DIY Timing Belt at 104k
    Hidden Hitch & Airlift 1000's

  5. #4
    Registered User
    Join Date
    Nov 2011
    Location
    California
    Posts
    17
    Thanks for your guidelines ...

    For New Dad New Van - The previous owner did change the Spark Plugs @ 80K ... Not sure if her mechanic used the OEM NGK or something else ... Also, do you think the changing the Spark Plug Coils and/or the EGR valve would help with the acceleration roughness ??? ...

    For OdyinNH - I have read the thread about the P1456 ... Did you use Prematex 80003 #1 Form-A-Gasket to seal the cracked ???

    As for checking the spark plug coils, what are the steps that I should follow to check them one by one ??? ... Please let me know ...

    I am planing to work on my Odyssey this weekend and will take detailed pictures of all steps to post them in this thread ... Thanks

  6. #5
    Registered User New Dad New Van's Avatar
    Join Date
    Dec 2003
    Location
    Canada
    Posts
    5,562
    Do you have any other codes such as P1491 or P0401?

    I would check the EGR valve first before replacing.

    Remove the connector at the EGR valve. Turn ignition switch to OFF.

    1 2 3
    4 6

    At the EGR valve side, measure resistance between EGR valve 6P connector terminals No. 1 and No. 2.
    Is there continuity or resistance of 100 kΩ or more?
    YES - Replace the EGR valve.
    NO – Go to next step.
    Measure resistance between EGR valve 6P connector terminals No. 1 and No. 3.
    Is there 100 kΩ or more?
    YES - Replace the EGR valve.
    2001 Odyssey LX
    2003 ACURA EL Touring

    UNOFFICIAL 2001 ODYSSEY THREAD: http://www.odyclub.com/forums/showth...664#post384664

  7. #6
    Registered User
    Join Date
    Nov 2011
    Location
    California
    Posts
    17
    Thanks New Dad New Van ...

    I am not getting any Codes (P0401) ... I will try to measure the resistance and report it to you ...

    How about checking the spark plug coils ??? ... Any recommendation of how to check them one by one ??? ... I have attached a picture of the Odyssey Ignition Coil for reference ...

    Also, I have read that the Knock sensor might cause some acceleration roughness issues ... Is that true ???

    It feels like I am going uphill when going from 0 to 20 ...

    Thx ...
    Attached Images Attached Images

  8. #7
    Registered User
    Join Date
    Oct 2006
    Location
    New Hampshire
    Posts
    1,392
    Quote Originally Posted by rahanna View Post
    For OdyinNH - I have read the thread about the P1456 ... Did you use Prematex 80003 #1 Form-A-Gasket to seal the cracked ???

    As for checking the spark plug coils, what are the steps that I should follow to check them one by one ??? ... Please let me know ...
    I used whatever I had for silicone gasket in a tube. As for the coils, you unplug one at a time while idling, each one should make the idle speed change. If you unplug one and the idle is not affected then it is probably bad. You mentioned knock sensor, a rodent chewed the wire on mine rendering it useless and it did not affect the engine in any noticeable way but did create a code. Do check the plugs and make sure the previous owner didn't cheap out on them.
    Mike
    2000 Odyssey LX
    Trans at 82k -- Tru-cool trans cooler
    DIY Timing Belt at 104k
    Hidden Hitch & Airlift 1000's

  9. #8
    Registered User
    Join Date
    Nov 2011
    Location
    California
    Posts
    17

    First problem P1456 is Solved with Pictures

    As promised, I did the job on Saturday and pictured the steps for those who are suffering from P1456 ...

    The attached [10] pictures are step-by-step instructions of what I have exactly done ...

    The P1456 is definitely and with no doubt related to the fuel neck connection to the fuel tank and by using #1 Form-A-Gasket you can finish the job in less than 1 hour ...

    There are [2] bolts that you need to take out to allow the fuel tank neck to be loose and be able to drop it as shown to take off the metal cap ...

    After I finished the job and reset the Check Engine Light, drove for over 150 miles and the CEL didn't come back ... I even did a Smog Check and it passed.

    I owe you guys helping me with the idea which my mechanic was surprised that it did work ...

    Now I need to solve the roughness and sluggish acceleration problem ...

    Hope to get another brilliant idea to troubleshoot it ... Thx
    Attached Images Attached Images
    Last edited by rahanna; 12-13-2011 at 12:17 AM.

  10. Remove Advertisements
    OdyClub.com
    Advertisements
     

Similar Threads

  1. Van Coded P1456 More Than A Gas Cap?
    By FYOUNG in forum 1999 - 2004 Odyssey
    Replies: 3
    Last Post: 01-17-2009, 11:40 AM
  2. P0420 plus P1456
    By gccch in forum Problems and Concerns
    Replies: 23
    Last Post: 05-22-2008, 01:38 AM
  3. 98 Ody with CEL P1456
    By bradyb in forum 1995 -1998 Odyssey
    Replies: 1
    Last Post: 06-13-2006, 01:48 PM
  4. P1456 Evap issue TSB
    By rajdeep_m in forum Problems and Concerns
    Replies: 0
    Last Post: 06-22-2005, 11:44 AM
  5. Help pls - CEL came on - Code P1456
    By B747_1000 in forum Problems and Concerns
    Replies: 5
    Last Post: 09-19-2003, 12:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2