clicking sound in front of driver firewall (engine side) and heater blowing cold air
NEWS
 

  1. Welcome to Honda Odyssey Forum : Odyssey Minivan Forums General discussion forum for Honda Odyssey

    Welcome to Honda Odyssey Forum : Odyssey Minivan Forums - a website dedicated to all things Honda Odyssey.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Honda Odyssey Forum : Odyssey Minivan Forums today!
     
+ Reply to Thread
Results 1 to 8 of 8

Thread: clicking sound in front of driver firewall (engine side) and heater blowing cold air

  1. #1
    AHJ
    AHJ is offline
    Registered User
    Join Date
    Mar 2005
    Location
    Canada
    Posts
    47

    clicking sound in front of driver firewall (engine side) and heater blowing cold air

    Hi

    I'm working on troubleshooting a no heat issue and I noticed a clicking sound coming from this (relay?) object. If you recognise it, please let me know.

    Odyssey 99 LX.
    Heater blows cold air.
    Radiator fluid full. Upper hose hot, lower hose cold.
    Heater core pipes in engine bay : passenger side warm, driver side cold.

    Thanks
    Attached Images Attached Images

  2. Remove Advertisements
    OdyClub.com
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Nov 2011
    Location
    USA
    Posts
    397
    Problem with no heat commonly due to heater valve stuck or broken. You might like to check it out first. Here is one of the many helpful link on this topic.

    no heat from my auto climate control system...

    Hope this helps,
    Bruce

    02' ex 245k+ miles

  4. #3
    AHJ
    AHJ is offline
    Registered User
    Join Date
    Mar 2005
    Location
    Canada
    Posts
    47
    Thanks, I'll check it in the daytime.

    My LX does not have Auto Climate Control - just a rotating knob cold to the left and hot to the right.

  5. #4
    Registered User mjody's Avatar
    Join Date
    Nov 2006
    Location
    B.C.
    Posts
    2,469
    Your pic is an emissions solenoid, unrelated to your issue. The heater valve is on the firewall and controls coolant through the heater core.
    2004 TL
    2000 Ody

  6. #5
    AHJ
    AHJ is offline
    Registered User
    Join Date
    Mar 2005
    Location
    Canada
    Posts
    47
    Thanks also mjody: wonder why it clicks on to glory.

    Update: Getting a lot more heat now after
    - Did a radiator flush with Prestone coolant flush
    - Changed the cabin air filter
    - vacuumed the condenser drip tube.
    - whacked the heater valve, thermostat housing and chute like structure under the glove box.
    - ruined the radio. Won't turn on anymore. The volume /power switch doesn't click.
    Will check progress over the next few days.

  7. #6
    Registered User mjody's Avatar
    Join Date
    Nov 2006
    Location
    B.C.
    Posts
    2,469
    It is a purge control solenoid, should click when working.
    2004 TL
    2000 Ody

  8. #7
    AHJ
    AHJ is offline
    Registered User
    Join Date
    Mar 2005
    Location
    Canada
    Posts
    47
    Radio works now, it was the 15A fuse in the fusebox at passenger's side footwell.

    (Fuse was on upper row, leftmost column - closest to the firewall)

    This fuse also controlled the 12V lighter outlet st the bottom of the centre console.

  9. #8
    AHJ
    AHJ is offline
    Registered User
    Join Date
    Mar 2005
    Location
    Canada
    Posts
    47

    Question

    Finally got to troubleshooting a little more.
    Heater valve works. There is heat on both sides when open. Took off hose on passenger side and coolant drips at extreme heat position (valve open). Stops dripping when closed (Extreme Cool)
    There's an aluminium pipe coming out of the firewall which a hose connects to the water valve. This pipe was crimped flat. I have an out of focus picture of it here.
    I have a feeling this was due to my previous efforts to get the hose off.
    The heating makes the inside comfortable but not toasty so will continue with the troubleshooting.

    Face level vent Foot well
    Drivers Side: Hot Lukewarm
    Passenger's side: Cold Didn't check
    Back: cold (only one vent)

    Thermostat was changed last summer by mechanic.
    Attached Images Attached Images

  10. Remove Advertisements
    OdyClub.com
    Advertisements
     

Similar Threads

  1. Replies: 0
    Last Post: 07-25-2011, 09:58 PM
  2. 2006 LX Rear AC blowing hot air;front ac still cold
    By sevy in forum 2005 - 2010 Odyssey
    Replies: 1
    Last Post: 04-28-2011, 10:29 PM
  3. Clicking engine noise when cold
    By ianw in forum 1999 - 2004 Odyssey
    Replies: 16
    Last Post: 05-12-2009, 05:13 PM
  4. Heater blowing cold air --Warm air in the back
    By kukmiker in forum 1999 - 2004 Odyssey
    Replies: 4
    Last Post: 11-30-2007, 02:01 PM
  5. Sound from passenger side (blowing air)
    By djadav in forum 1999 - 2004 Odyssey
    Replies: 5
    Last Post: 12-04-2006, 01:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2