2000 Honda Odyssey Engine Oil Leak on Passenger Side from Bottom near steering Rubber
NEWS
 

  1. Welcome to Honda Odyssey Forum : Odyssey Minivan Forums – General discussion forum for Honda Odyssey

    Welcome to Honda Odyssey Forum : Odyssey Minivan Forums - a website dedicated to all things Honda Odyssey.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Honda Odyssey Forum : Odyssey Minivan Forums today!
     
+ Reply to Thread
Results 1 to 12 of 12

Thread: 2000 Honda Odyssey Engine Oil Leak on Passenger Side from Bottom near steering Rubber

  1. #1
    Registered User
    Join Date
    Dec 2012
    Location
    PK
    Posts
    4

    2000 Honda Odyssey Engine Oil Leak on Passenger Side from Bottom near steering Rubber

    Hi
    I have a Engine Oil Leak on Passenger Side. The oil is leaking from a pipe that is connected to a round thing which also has a green color. the electrical connector is also connected to it. this pipe runs from the top Passenger side of engine to bottom. I need to know the part name so i can order it. The leak is near to steering rubbers. (the thing in which we put steering oil from top)
    Thank U

  2. Remove Advertisements
    OdyClub.com
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2010
    Location
    Minneapolis, MN
    Posts
    305
    Best to post a photograph here. You sure it's not coolant or power steering fluid?
    2002 Odyssey 160K, 1st tranny rebuild at 129K
    '89 Honda Goldwing
    '89 Mercedes 190 2.6L

  4. #3
    Super Moderator dvpatel's Avatar
    Join Date
    Jun 2001
    Location
    Pineville (burb of Charlotte), NC
    Posts
    13,201
    Quote Originally Posted by aaronm View Post
    Best to post a photograph here. You sure it's not coolant or power steering fluid?
    And to correct the location in the profie. PK which I read as Pakistan is a hot bed of spammers. I almost blew this post away. Glad I checked the IP.
    When I use this smilie ===> Hidden Content I am NOT calling you stupid. Hidden Content Hidden Content Hidden Content

    The value of a forum such as this one is not in that one can post a question and receive an answer, but in that the question has most likely been asked before, and the answer is available to him that will but only use the Hidden Content .

    2007 EX-L R&N, Slate Green with Olive (couldn't muster up the courage to trade my 1999 baby) ... Ours

    2001 Emerald Green Pearl Accord V6-LX (Replaced the POS Taurus) ... Hers ...
    ..... Tranny replaced 6/4/08 @ 67,977 miles.
    ..... Tranny strarted slipping only 8,414 miles after the replacemnt.
    ..... 2nd tranny replacement 9/21/2009 @ 76,659 miles.
    1999 Sterling Mist Nissan Maxima SE with Bose and 6 Disc CD Changer in the trunk ... All Mine

    1993 Maroon Ford Taurus GL (Was a POS after the clock turned 60K Miles) ... Traded for the Accord

    alexmish1's Hidden Content
    alexmish1's Hidden Content

  5. Remove Advertisements
    OdyClub.com
    Advertisements
     

  6. #4
    Registered User
    Join Date
    Dec 2012
    Location
    PK
    Posts
    4
    Its not Engine coolant, neither Steering Oil. Its neither the seal of Engine.
    I will post a photograph on Saturday.
    Thanks

  7. #5
    Registered User
    Join Date
    Apr 2003
    Location
    Seattle, Wa
    Posts
    248
    From my experience, I would suggest ruling out loose drain plug or failed crush washers and loose oil filter first, prior to thinking the seal is the problem

  8. #6
    Registered User
    Join Date
    Dec 2012
    Location
    PK
    Posts
    4
    IMG_2527.jpgIMG_2528.jpgIMG_2529.jpgIMG_2530.jpgIMG_2531.jpg
    u an see that green ring like thing its leaking. the pipe from engine (engine oil) is also connected to it. this pipe is on passenger side near accessory belt. there is only one pipe there. the rightmost picture is taken from underneath the car. rest of the picture r from top.
    Sorry for my late response.
    Thank U
    Last edited by muhammadazeem; 10-20-2013 at 02:51 PM.

  9. #7
    Registered User
    Join Date
    Oct 2008
    Location
    KC
    Posts
    5
    Is that the oil pressure switch?

  10. #8
    Registered User
    Join Date
    May 2008
    Location
    Dallas
    Posts
    849
    Looks like the power steering pressure switch to me.

    So where are you located? You did not change your location from what appears to be Pakistan!
    2002 Ody
    140k miles, original transmission

  11. #9
    Registered User
    Join Date
    Dec 2012
    Location
    PK
    Posts
    4
    The Location doesn't matter its all about work these days. thank u

  12. #10
    Registered User
    Join Date
    Dec 2011
    Location
    southeast
    Posts
    116
    That is the power steering pressure switch. It doesn't have an o-ring so check to be sure it is not loose or that the metal pipe does not have a pin hole in it. Also make sure that the boot isn't slinging grease on the switch.

  13. #11
    Registered User
    Join Date
    Oct 2006
    Location
    Westchester, New York
    Posts
    83
    I agree.

  14. #12
    Registered User 0dyfamily's Avatar
    Join Date
    Jun 2006
    Location
    SW OK on the Red River
    Posts
    6,194
    Quote Originally Posted by tron3107 View Post
    that is the power steering pressure switch.
    +1.

    Of
    2003 Ody EX-L RES 158k miles, OEM fogs & hitch, bbylon5 screen mod, chuck k fog mod#2, cnn 82C t-stat mod
    2002 Ody EX RES 164k, Ditto on above.
    1998 Accord LX215k. DIY: Haynes 676 ATF cooler; T & acc belts & tensioners.
    1982 Ebbtide DynaTrak bass boat, 200hp Merc, DIY re-fit 2006-07: CMC jackplate, Teleflex Canada Steering, Torque-Shift 14-26 vari-pitch SS prop
    SNAPPER mower 5.5hp Honda

    Hidden Content

  15. Remove Advertisements
    OdyClub.com
    Advertisements
     

+ Reply to Thread

Similar Threads

  1. Oil leak and engine mounts 2003 Odyssey
    By rcarbia in forum 1999 - 2004 Odyssey
    Replies: 2
    Last Post: 04-15-2013, 10:31 AM
  2. Slow oil leak 97 Ody near middle to passenger side
    By alikal in forum 1995 - 1998 Odyssey
    Replies: 4
    Last Post: 10-20-2012, 03:58 PM
  3. 2000 Honda Odyssey EX Passenger Side Power Sliding Door
    By saa85 in forum 1999 - 2004 Odyssey
    Replies: 0
    Last Post: 06-18-2010, 06:01 PM
  4. Oil leak 2000 Odyssey passenger side
    By bobintn in forum 1999 - 2004 Odyssey
    Replies: 10
    Last Post: 05-20-2010, 11:40 AM
  5. Water Leak from right rear of engine near bottom
    By markcampbell in forum Problems and Concerns
    Replies: 6
    Last Post: 04-27-2008, 01:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2