Engine Revving by itself
NEWS
 

  1. Welcome to Honda Odyssey Forum : Odyssey Minivan Forums General discussion forum for Honda Odyssey

    Welcome to Honda Odyssey Forum : Odyssey Minivan Forums - a website dedicated to all things Honda Odyssey.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Honda Odyssey Forum : Odyssey Minivan Forums today!
     
+ Reply to Thread
Results 1 to 7 of 7

Thread: Engine Revving by itself

  1. #1
    Registered User
    Join Date
    Jan 2002
    Location
    Vista, CA
    Posts
    6

    Engine Revving by itself

    This morning out of the blue, my '02 EX with ~65,000 miles started revving by itself. When sitting in park or neutral the engine will rev up and down by itself, continuously cyclng between 1000 and 1500 rpm. It is not noticable when in drive. The fact that it wasn't doing it yesterday makes me think component failure. The lease is done next month I spent the last two days detailing it for the end of lease inspection the day after tomorrow! YIPES! I don't want to take a hit on the vehicle value and would prefer to fix it myself to save some money. Any body have any ideas where to start looking? HELP

  2. Remove Advertisements
    OdyClub.com
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Sep 2004
    Location
    Seattle, WA
    Posts
    536
    How's your battery?

    I had that happen to me on an 97 Acura CL 3.0. Same basic engine design, just smaller.

    The battery drained down to almost nothing... Barely cranked over. Once it started, it kept doing that revving by itself back and forth from idle up to around 1500-2000.

    I took it for a LONG freeway drive and it stopped doing that.

  4. #3
    Registered User
    Join Date
    Jul 2004
    Location
    Ottawa, Canada
    Posts
    4,367
    Mine did the same thing one time, except while driving too. So I pulled over and shut off the engine for a minute. Has never happened since. Wait until tomorrow and yours will probably fix itself too.

    - Dave
    2002 Odyssey EX Fern (Granite) Green
    Honda hood deflector, mud guards, AC condenser screen mod, Zyml wax, Amsoil Ea15KO20 oil filter, Amsoil synthetic 5W20, Krown rustproofing, block heater (gets cc...cold in Canada in winter!)
    Original transmission at 121,000 miles/195,000 km, Amsoil ATF since 79,000 miles/127,000 km, Honda aux ATF cooler, Magnefine aux ATF filter, 16 ATF drain & fills

  5. #4
    Registered User William Wiles's Avatar
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    3,163
    Search pn broken wire in power steering cable. That is a common problem on the Ody.....
    2004 EX Odyssey.
    All posts made by me are in reference to the gen 2 Odyssey.

  6. #5
    Registered User
    Join Date
    Feb 2002
    Location
    Elkridge, MD
    Posts
    68

    I've seen that...

    I had a similar problem but it got worse fairly quickly with the idle RPM moving all over the place. Eventually, the TCS/ABS light came on and I got it to the shop. The shop indicated that the problem was with the Idle Air Control Valve and Catalytic Converter.
    '05 Desert-Sand EXL-DVD-NAVI
    '02 Mesa-Beige EXL-RES
    Towing Package
    Crossbars
    Fog Lights

  7. #6
    Registered User
    Join Date
    Nov 2005
    Location
    Frederick
    Posts
    2
    Hey..
    our 2003 started to do this...
    1st appointment: the idler control valve replaced.
    still surging
    2nd appointment: complete ECU replacement.
    still surging
    3rd appointment: found that the powersteering switch was broke or disconnected.

    Now, no surging

    hope this helps.

  8. #7
    Registered User GOTTI's Avatar
    Join Date
    Oct 2005
    Location
    Riverview, Florida
    Posts
    58
    mine did this also a few weeks ago. I pulled the ecu backup fuse...reset the ECU and it has been fine since. I guess i will have to look at the power steering switch, maybe it got knocked loose when i he timing belt was changed.

  9. Remove Advertisements
    OdyClub.com
    Advertisements
     

Similar Threads

  1. Engine revving high after sitting in garage
    By vanomore in forum Problems and Concerns
    Replies: 2
    Last Post: 01-11-2010, 05:24 PM
  2. Intermittant engine revving during driving
    By kg2008 in forum Problems and Concerns
    Replies: 4
    Last Post: 12-08-2008, 12:11 PM
  3. Engine revving up with speed decrease
    By ODCfan in forum Problems and Concerns
    Replies: 5
    Last Post: 05-17-2005, 01:27 PM
  4. Check Engine - TCS - Revving
    By liquid007 in forum Problems and Concerns
    Replies: 2
    Last Post: 12-28-2003, 06:33 PM
  5. Engine revving while braking
    By icydon62 in forum Problems and Concerns
    Replies: 5
    Last Post: 08-19-2002, 05:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2