AC Compressor not engaging
NEWS
 

  1. Welcome to Honda Odyssey Forum : Odyssey Minivan Forums – General discussion forum for Honda Odyssey

    Welcome to Honda Odyssey Forum : Odyssey Minivan Forums - a website dedicated to all things Honda Odyssey.

    You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, Join Honda Odyssey Forum : Odyssey Minivan Forums today!
     
+ Reply to Thread
Results 1 to 4 of 4

Thread: AC Compressor not engaging

  1. #1
    Registered User
    Join Date
    Mar 2017
    Location
    Whitewater, CO
    Posts
    14

    AC Compressor not engaging

    On my '02 Odyssey. It got it from a friend. He replaced the AC compressor as the last one went out. He changed the compressor, charged it and it didn't cool. Then he heard the deal about have to change out the whole system and decided to not spend any more money on it and I grabbed it.

    So, I put in a new condenser on it and deleted the lines going to the rear AC (BTW, the old one was clogged). I charged it and the compressor won't kick in. So, I jumped the the low pressure switch....the idle goes up, the fans kick on but nada at the compressor.

    I checked the voltage, there is no juice going in to the compressor. I checked the fuses and didn't find any bad ones.

    Am I missing anything?

    I am tempted to just run 12v in to a toggle switch then to the compressor. I did that once before on my 80 toyota. It had a bad electronic controller and they were expensive.

  2. Remove Advertisements
    OdyClub.com
    Advertisements
     

  3. #2
    Registered User John Clark's Avatar
    Join Date
    Oct 2008
    Location
    Charlotte, NC
    Posts
    5,338
    You've got other problems besides getting power to the compressor. If the compressor failed it usually sends shards of metal throughout the system. These get lodged in the expansion valve, the condenser, the lines, and the evaporator. If you change the compressor you need to change the condenser (which you did) and you often need to flush or replace the lines and the evaporator (the part under the dash that gets cool.) If you don't do that you will just send that contamination into the new compressor and new condenser and you'll have to do the job again.

    You said the rear evaporator was plugged. Whatever plugged it is also in the rest of the system. How did you know it was plugged?

    How did you charge it? Did you vacuum the system prior to charging?

    As for the compressor not kicking on you will need a wiring diagram to get anywhere with it. Pull your compressor relay and see if you have two good power feeds to the relay with the key on. One will be the load side power feed and the other will be the control side power feed. The PCM gives the control side a ground which engergizes the relay and sends power through the load side to the clutch. You just need to figure out what you're missing (either a power or a ground) at the relay and work from there.

    http://www.revbase.com/BBBMotor/Wd/DownloadPdf?id=75585
    2008 Odyssey Touring-Silver
    2011 VW Jetta SE-Black
    2002 GMC Sierra SLT LB Z71-Red
    1998 Nissan 200SX SE-Blue

  4. #3
    Registered User
    Join Date
    Mar 2017
    Location
    Whitewater, CO
    Posts
    14
    The rear AC/evaporator was not tested...clogged, AFAIK.

    The condenser was what was clogged.

    When I charged it, I did a vacuum on it and then charged it.

    We drove it yesterday and the AC seems to work fine...I jumped the compressor wire and gave it 12v.

    Where is the compressor relay?

  5. Remove Advertisements
    OdyClub.com
    Advertisements
     

  6. #4
    Registered User John Clark's Avatar
    Join Date
    Oct 2008
    Location
    Charlotte, NC
    Posts
    5,338
    Quote Originally Posted by Stinky1 View Post

    Where is the compressor relay?
    Underhood fuse box.
    2008 Odyssey Touring-Silver
    2011 VW Jetta SE-Black
    2002 GMC Sierra SLT LB Z71-Red
    1998 Nissan 200SX SE-Blue

  7. Remove Advertisements
    OdyClub.com
    Advertisements
     

+ Reply to Thread

Similar Threads

  1. Alternator died and now ac compressor not engaging
    By Jeepers304 in forum 2005 - 2010 Odyssey
    Replies: 1
    Last Post: 06-28-2015, 08:25 PM
  2. 96 Overdrive Not Engaging Properly?
    By GuyC in forum 1995 - 1998 Odyssey
    Replies: 2
    Last Post: 02-03-2013, 01:02 PM
  3. Parking brake not engaging...
    By jlin in forum Problems and Concerns
    Replies: 4
    Last Post: 06-20-2012, 05:13 PM
  4. ac clutch not engaging
    By dugd111 in forum 2005 - 2010 Odyssey
    Replies: 2
    Last Post: 06-06-2010, 10:04 PM
  5. Trasmission engaging sound
    By mojoe721 in forum 2005 - 2010 Odyssey
    Replies: 8
    Last Post: 03-09-2009, 02:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Powered by vBadvanced CMPS v4.1.2