Honda Odyssey Forum banner

please help

  1. 2005 - 2010 Odyssey
    Hey All! Newbie here as far as Honda’s, or really anything newer than the 90s. I am trying to fix the 2005 Odyssey I bought for $450. Previous owner had taken it to a dealership and it was diagnosed blown head gasket due to failed radiator, this was after they replaced the spool valve. They...
  2. 1999 - 2004 Odyssey
    Hi! I have a 2004 Odyssey that is in hospice. We usually run our Honda's into the ground, donate, rinse and repeat. I have a friend who has a dog, Rusty, made from engine and crank shaft parts. I want to make my own, Cranky. I have access to an engine hoist, tools, working space, and all...
  3. 2011 - 2017 Odyssey
    Hello everyone, here is the situation my family is in, and we REALLY need advice so I am hoping someone here with more knowledge and experience can read this and help us out. I am going to try to be succinct, while including all necessary information: About a week ago our 2012 Honda Odyssey EX...
  4. 2005 - 2010 Odyssey
    Hi, Club I have a 2007 EX with 150K+ miles that I bought used. My Ody hasn't needed much in the way of work except a new alternator back in 2016. About a month ago, I noticed a burning smell coming through the air vents and from outside the car (was using the A/C, not the heater). My oil levels...
  5. 2005 - 2010 Odyssey
    I HAVE A 2007 HONDA ODYSSEY EX AND SLIDING SIDE DOORS SHUT DOWN WONT OPEN BY BUTTON SO I TOOK JUMP WIRE TO PIN 4 & 9 AND CAME UP WITH CODE- B2084 34 NOW I KNOW (34) MEANS THE RIGHT SIDE SLIDING DOOR BUT THE CODE- B2084 IS NOT SHOWN IN THE CHILTON'S REPAIR MANUAL CAN ANYONE HELP ME
  6. 2011 - 2017 Odyssey
    Hey Everyone, New to the Forum and do not even have an Odyssey yet, just need some help as the salesman at the dealership don't seem to be very knowledgeable. Below is my current situation and please correct me or give me any information you think I may need. My wife and I have 3 boys ages 5...
  7. 2005 - 2010 Odyssey
    I have an 2010 Odyssey and it is not blowing air up front to its full capacity. The air it blows is cold, but even at full speed the fans are only blowing at what feels like the lowest possible air setting. Does anyone has a solution to this problem? PS: I know nothing about cars at all please...
Top