Honda Odyssey Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I just purchase my Ody 06 EXL with nav &res. Have 69k on it. When the ECO come on and off around 30-60mph u cant really tell when it come on and off. Vehicle shakes alil bit. Im out of warranty so dont want to deal with dealership BS. N how often do u need to change the tranny fluid? N wat brand should I go with? Thanxs
 

·
Registered
Joined
·
16 Posts
i can't tell what you are really saying/asking. if it starts shaking when the eco comes on, then you give a little gas to kick it out of eco mode and the shaking (droning) stops, then i would look at the rear motor mount. if it shakes all the time then a fluid change might be needed. i use the honda spec oil and change whats in the pan (3 qts) every 3rd oil change. i currently have 122k on ours, no tranny issues to date.
 

·
Registered
Joined
·
583 Posts
Based on my invoice, drain and refill every 30k miles. There is supposed to be a new ATF from Honda too (hopefully to correct this popular problem). Many people use Amsoil with good result.
 

·
Registered
Joined
·
83 Posts
Sorry to tell you this but you torque converter is failing. Our '06 EXL/RES/NAV started shaking at 60k miles and it is pretty bad now at 76k.

Honda dealer is pretending that they know nothing about the problem.

Do an internet search for "odyssey judder" or "odyssey vibration" you will find a lot of info on the subject.

There is a TSB for the '07-'10 models for reprogramming tranny software.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
I probaly need to check my rear engine mount.. N change my tranny fluid or have it flush.. I hope its not the TC... Thats major money.
 

·
Registered
Joined
·
21 Posts
I had a vibration issue on our 05 EXL that sounds similar to yours. Replacing the rear engine mount solved the vibration issue and a rattling issue which I thought was unrelated.

I have also felt the occasional transmission "judder" in our van but it is a much different feel...kind of like running over very rough pavement.

Good luck.
 

·
Registered
Joined
·
583 Posts
2ndODY said:
I had a vibration issue on our 05 EXL that sounds similar to yours. Replacing the rear engine mount solved the vibration issue and a rattling issue which I thought was unrelated.

I have also felt the occasional transmission "judder" in our van but it is a much different feel...kind of like running over very rough pavement.

Good luck.
I also replaced the rear engine mount and that got rid of the judder or what I called "engine lug" and the vibration from the floor. But in less than year, the judder came back slightly when the weather was getting a little colder. I read someone's post about resetting the throttle by turning on the key and press on the gas pedal and it seemed to work. No problem so far despite the much colder weather. The shifting points in the whole range seems to change.

Yup, it started out with the "kind of running over very rough pavement".
 
1 - 7 of 7 Posts
Top