Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 07 Odyssey Touring Edition, and the rearview backup camera suddenly stopped working. The screen is just black when you put it in reverse.

My wife says it was working fine in the AM, then she noticed later in the day it was not working anymore. She said she might have slammed the back hatch door, instead of waiting for it to close automatically (impatient). No obvious changes to the camera or connector wires, though I haven't taken anything apart.

Any ideas? Searches don't show those cameras as failing a lot.

Has anyone replaced one of the cameras, or have ideas about other possible issues it could be?

Thanks in advance.

--DAvid
 

·
Registered
Joined
·
1 Posts
Hi DAvid. Same problem with a Japanese import 04 odyssey (I'm in New Zealand) I too would be interested if anyone else has found a repair
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Honda dealership says it is either the camera failing ($1500 to repair) or the navigation system ($3200). To troubleshoot they would swap out the navigation system with another working navigation system.


Did not pursue since that was an insane amount of money. Will research aftermarket backup cameras.
 

·
Registered
Joined
·
243 Posts
Hectic, both of those are insane amounts of money. You can get the navigation system off of Ebay for under $500 and as little as $300. The backup camera is much cheaper than this. I would try another dealer or just pay them the diagnostic fee to tell you which one is bad and replace it yourself or find an independent shop to do it.
 
1 - 4 of 4 Posts
Top