Honda Odyssey Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hey all,
First post. Got a story I'll try to keep it short. My '07 Odyssey has beensitting at a body shop since Dec 15. I picked it up yesterday, Jan 13. Fuel wasalmost on E. I stopped at the nearest major gas station (Valero) here in TX and filled it up. Drove it approx 25-30 miles towards home without any issues, but when I was exiting in traffic, I had both the check engine symbol and the VSA lights come on. It was a bit sluggish and acted as if it wanted to die on me. I got it off the road and called both the dealer, and a mechanic that we know.The dealer (when I told him about the gas after sitting empty for a month) told me that the fuel system had been contaminated and to hurry on in and they wouldn eed to flush the system, the injectors, blah blah blah....I could just hear his cash register clanging, so I said I'd call back.....The I called, and went by the mechanic I know and he hooked it up to a scanner and it pulled a code something like ecm/pcm error system not communicating....or something like that, sorry i didn't get the numerical code. His diagnosis is possibly the the ecm (computer?) had possibly failed. I don't know, but it seems odd, that before my little accident (yes, that's why it was at the body shop), I'd had no problems, and didn't have any for the first 30 miles of driving. Does anyone have a clue where to start? Could it be the fuel? Could it be the computer got banged a bit in my minor accident? I did not deploy air bags or lose any fluids, so I was thinking I was in good shape....Any help appreciated....Thanks.
 

·
Registered
Joined
·
21 Posts
Get a hose and suction the stuff out yourself. If that's what is really makin your Odyssey run sluggish, you'll know pretty quick. and if it's not, then it clings the register.
 
1 - 2 of 2 Posts
Top