Honda Odyssey Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I'm 1st time Odyssey owner, bought 2004 EX-LRES with 74,000 miles. Love it & ran great on recent trip with 3 Grandkids to visit Great-Grandmas out of state & couple other trips. Now has 77,500+ miles. Traded in my 2003 Maxima with 143,000 to get the Odyssey. Been reading about tranny problems & was unaware of it prior to trade for Odyssey & also learned could be an issue along with motor mounts? Should I get both motor mounts & tranny checked out by Honda dealer? Maybe it's power of suggestion but it does appear mine does a little jerking sometimes in 2nd or 3rd gear when I accelerate slowly. Today while going up a hill slowly, I felt the van do some lurching or jerking in low gear @ slow speed (25-30 mph). Not all the time. Got an issue too with the CD player - won't play, reads "DISC" then ejects no matter how many times I insert the CD. I do have the battery disconnected tonight & joined + & - cables for 15+ minutes based on reading other threads. Otherwise, my wife & love this van. Thought about changing trans fluid myself & using DEXRON III but noticed manual says use genuine Honda trans fluid only & DEXRON III as temporary replacement. I suppose genuine Honda trans is quite expensive? I'm reading old posts/threads to acclimate myself so please don't get upset with me, I WILL catch up & catch on eventually. Thanks
 

·
Registered
Joined
·
6 Posts
Heard from my mechanic, honda original ATF-Z1 transmission oil needed, it's not expensive at all.

CD player issue, I guess the optical reader failed, none of the business of the battery.

I'm not sure the price of genuine trans, learnt from forum that the price is around 3K-5K.
 

·
Registered
Joined
·
32 Posts
I would change the fluid with the Honda Z1. I ordered a whole case (12 bottles)of it from a seller on Ebay for around $75 with shipping. Save a few dollars over the cost from the dealer. I did the drain and fill 3x with the driving in between. It helped with some roughness after the 2nd drain and fill.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Thanks for the input on the tranny. I will try to get some Honda trans fluid & attempt to do the drain/refill 3 times - yikes! Is the drain plug really on TOP of the tranny? Is that what I read in the other posts?
Funny thing on the CD player - after leaving battery disconnected overnight, reconnected today, did code on the radio/CD player, problem persisted: "DISC" flashed 3-4 times, CD was ejected. Must be the "eye"/reader. BUT..my battery acted really low & engine turned over slowly all day after several starts, so I'm gonna replace the battery just to be safe.
Anybody got a recommendation on my ? about motor mounts? Or is the shuddering in low gear all tranny issues? Man, I hope the tranny is still good, I wanna drive this van for 200,000+ miles!
 

·
Registered
Joined
·
447 Posts
The shuddering sounds like the "common" EGR problem. Compared to tranny that's relatively easy/cheep to repair. Is your CEL light on?
You will see the engine move when revving in gear if you have bad mounts. That's yet another common problem.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
EGR, huh? Well, that adds another "wrinkle" to the situation. Thanks for the heads up. I owned an '87 Honda Accord in the distant past & it provided great service for years so figured if this Odyssey was a Honda then I was guaranteed virtually few if any problems. Guess I gotta change my thinking! I've owned "American" made cars too & had more problems with them than "imports" but perhaps the gap is closing? Anyway, thanks, I'll get the EGR checked tho no "check engine" light or "service soon" light is currently displayed.
 
1 - 6 of 6 Posts
Top