Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i just bought this van for the fam :DD but the rear air doesn't work? :huh: tried the front controls and tried the rear controls. nothing. can anyone can point me in the right direction where i should start looking at first? t.i.a.

I also have this other problem with the van in the front end by the wheels. I always here thumps when i run over little bumps or cracks on the city roads. seems to me like it thumps more then it should but the suspension seems fine tho. The van does need an alignment as the steering wheel is about 3 inches off to the left when going straight. I am waiting on that since i have to buy new tires anyways.

also does your odo light up at night? :huh: the numbers......? curious cause mine doesn't. and does anyone know where i can download an updated navi maps for this year ody?

sorry for so many questions but I hate when **** dont work right!! I would appreciate any great inputs.
 

·
Registered
Joined
·
6,074 Posts
The thumping in the front could be a loose brake caliper pin(s). The odometer needs a bulb changed.
 

·
Registered
Joined
·
3,163 Posts
The thumping could be anything in the suspension. Guessing won't fix it. The only way to find out is jack it up, pull the wheel and inspect the suspension. Something is loose or broken.
 

·
Registered
Joined
·
3,406 Posts
i just bought this van for the fam :DD but the rear air doesn't work? :huh: tried the front controls and tried the rear controls. nothing. can anyone can point me in the right direction where i should start looking at first? t.i.a.
A little more descriptive? Is it blowing air out the top vents but it's not cold? Is the fan not running back there? Does it blow out the lower vents when set to heat? Need some direction.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5 (Edited)
ok i fixed the bulb today. it works perfect now and as far as how the rear air problem is going, i found out that the knob from the front was broken so i took it off and turned it to where it will allow the rear to control it. now it works and for both cold and hot air. I stopped by my cousin's shop today and had him look at the thump. the slightest bumps would make it thump. i started to have this shake at the wheels when turning right and he said that it may be my ball joints going bad. he pushed up and down on the car to see if it were the shocks that were back but the shocks seemed good. no excessive play. then to determine if it was the ball joints or not he put both hands on the wheels/tires and pushed it left and right and there was no play. up and down and still no play. so it doesn't seem like its the ball joints. my search continues......still don't know what it is........has anyone ever had this problem?? my ody has 146k miles.
 
1 - 5 of 5 Posts
Top