Honda Odyssey Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a noise going over bumps from the right front side. I have had the struts replaced including bearings, sway bar bushings,stabilizer links, hub bearings. Ball joints and caliper bolts are good. I do have some lateral play in the half shaft bearing near the inner cv joint. Cv joints are original with 132k miles. Is lateral play acceptable in the bearing. CV Boots are intact. Would this bearing make a noise when going over bumps. It is more pronounced when going over slow speed bumps. All trans and engine mounts are good. Help
 

·
Registered
Joined
·
419 Posts
Lower Ball Joint or Upper control arm.. I had that issue with my 04, replaced the lower joint and Upper arm with new upper joint. Noise stopped.


P.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I thought I read someplace about a tsb for a problem in the strut mount regarding a weld that needed to be grinded down. I wonder if this is my problem. I tried searching for the tsb and I could not find it. Thanks for the help
 

·
Registered
Joined
·
447 Posts
Did you check the brake caliper? Mine was so loose you could make it clunk by hand.
Make sure the caliper is not hot when you grab it.
Search "caliper pin" for a fix or replace the caliper.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I am going to go back and double check the calipers. Is it the slide pins that go bad or the caliper mount that the pins slide into or both that go bad?
 

·
Registered
Joined
·
6 Posts
I had the same issue with my '03 (140k miles) I had to replace the caliper guide pins. The lower pin was seized and "dry". I used high temp antisieze and replaced the pins. No more vibration from the wheel.
 
1 - 8 of 8 Posts
Top