Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
161757


So my new to me odyssey has had some Rev controlling (surging?) problems i noticed. First, at idle, revs up and down maybe 200rpm and when holding it at a rpm it moves also.
2nd week driving it I noticed a slight hesitation of the gas at random speeds, freshly rebuilt transmission.
Works A1 except for the odd drive.

Changing my sparkplugs on the cabin side I noticed this rusty POS haha. Looks important and need to be replaced. Anybody know what it is?

I do have a broken wire on a sensor I believe is for the power steering that could be 1 culprit.
IAC? EGR? Valve adjustment?

Any other comments would be great before I tear into it. Local stealership wants 190$ to diagnose problem
 

·
Registered
Joined
·
260 Posts
There are a bunch of threads on this oscillating idle for which Honda seems to be famous for.
I had a sticking IAC after I cleaned my throttle body and it oscillated wildly from 1000-2500 rpm.
Picture looks like it may be the heater control valve. Anything rusty like that on my Ody I spray with Fluid Film rust inhibitor and lubricant.
 
  • Like
Reactions: 0dyfamily

·
Registered
Joined
·
9,320 Posts
I do have a broken wire on a sensor I believe is for the power steering that could be 1 culprit.
That's the power steering pressure sensor. A broken wire (common issue BTW) can indeed cause a fluctuating idle.

When it's working normally and PS pressure drops, the computer requests a higher idle speed. When the wire is broken, the computer cyclically requests faster and slower idle.
 

·
Registered
Joined
·
167 Posts
Also make sure your throttle cables are adjusted properly especially the cruise control cable that clips onto the intake duct, air cleaner housing and wraps around to the CC unit on the passenger side.
 

·
Registered
Joined
·
1 Posts
View attachment 161757

So my new to me odyssey has had some Rev controlling (surging?) problems i noticed. First, at idle, revs up and down maybe 200rpm and when holding it at a rpm it moves also.
2nd week driving it I noticed a slight hesitation of the gas at random speeds, freshly rebuilt transmission.
Works A1 except for the odd drive.

Changing my sparkplugs on the cabin side I noticed this rusty POS haha. Looks important and need to be replaced. Anybody know what it is?

I do have a broken wire on a sensor I believe is for the power steering that could be 1 culprit.
IAC? EGR? Valve adjustment?

Any other comments would be great before I tear into it. Local stealership wants 190$ to diagnose problem
The rusty POS looking like the heater core valve. If one end of the hose goes into the firewall that would be what it is.
 
1 - 5 of 5 Posts
Top