Honda Odyssey Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have smelled coolant and seen some coolant leaking on the front engine mount on my 02 EX Odyssey (96,000 miles). From what I have been reading in the forum, it might be leaking from the water passage.
I would like to change the water passage gasket and also replace the o-rings on the connecting pipe. I saw some threads regarding this problem but just wondering if anyone has tried to change the 2 o-rings on the connecting pipe, especially the one from the water pump. I didn’t see any nuts and bolts holding the pipe on the Honda Servie manual so I think it is just a matter of pulling the pipe out, replace the o-rings and put it back. Please advise if you think it is a right way to do and thanks everyone for all the informative and helpful info.
 

·
Registered
Joined
·
4 Posts
I did exactly what you said. Remove the water passage. It took about 15 minutes of wiggling before I got it out. That left the connecting pipe with the o-ring on it on the engine. A simple twist and i got the connecting pipe out where it was attached at the other end to the water pump. There were no other nut to remove. The connecting pipe was sandwiched between the water pump and the back of the water passage. However, the Honda tech advisor at the dealership from whom I got my o-rings and gaskets says that there is a nut holding the pipe down. I did not see one. I told him I have a 2005 EX-L iVTEC engine. I am not sure if he is thinking of 2004 or earlier models.
 

·
Registered
Joined
·
7 Posts
connecting pipe

I did exactly what you said. Remove the water passage. It took about 15 minutes of wiggling before I got it out. That left the connecting pipe with the o-ring on it on the engine. A simple twist and i got the connecting pipe out where it was attached at the other end to the water pump. There were no other nut to remove. The connecting pipe was sandwiched between the water pump and the back of the water passage. However, the Honda tech advisor at the dealership from whom I got my o-rings and gaskets says that there is a nut holding the pipe down. I did not see one. I told him I have a 2005 EX-L iVTEC engine. I am not sure if he is thinking of 2004 or earlier models.
I needed to remove the water passage on a 2003 odyssey because the thermostat housing would not seal. The connecting pipe disconnected from the water pump side it has the same “O” ring on both sides. Is there a method to put it back or just push it back in?
 
1 - 3 of 3 Posts
Top