Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2003 with 80K on it. The cruise control intermittently fails. It will be fine for a while, then cuts out and not reset. It will also spontaneously accelerate (slowly) on occasion until it is about 8 mph over the set speed, then it cuts out. If I try to reset it, it usually won't unless I shut the system off, then back on. After a couple times of this it will not reset at all. Sometimes when I begin the trip, I will use it and it will work fine for 30 miles, but when I make any changes, it may start acting up. It doesn't seem to matter if I use the brake, or cancel, or just shut it off. I've had lots of time to play with it as I've been dealing with this problem for a year or two. It'd be nice to know if anyone has found a fix for it yet. It seems to me that it would likely be the control module since it will often resume normally or fail with any of the possible options. Even when I try just using the cancel button, or just the power button, or just the brake. It doesn't seem to make a difference. Any advice would be appreciated.
 

·
Registered
Joined
·
72 Posts
Check the brake pedal position switch. It has two sets of contacts; one set closes to turn on brake lights, the other opens to shut down cruise control. It's known to fail and it's only about $10 from the dealer. Quick, easy install, too.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I thought of that because I've noticed how many people have posted a similar problem, however, I'm not sure that a faulty brake switch would cause it to accelerate spontaneously.
 

·
Registered
Joined
·
78 Posts
From an old post of mine:
The cruise had been acting up for 3 months. Sometimes it wouldn't engage at all, other times the buttons would be mixed up (accelerate when cancel was pushed!!!)

The diagnostic: they "think" the cable reel in the steering column needs to be replaced. They told me that it would be covered under the 5Y/100 000km powertrain warranty (I have 90 000km). It is ordered and will be installed next week. Hopefully it will solve both problems. I'll post with results.

The stored codes were 1140 and 9220
The reel assembly cable (part 7790-S0X-A22) was the culprit! Both SRS and cruise control problems fixed.

Cost: 20$ for the diagnostic, the part and labor cost was covered by warranty.

I'm happy!
 
1 - 4 of 4 Posts
Top