Honda Odyssey Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Twice now I have had my 2004 Odyssey demonstrate this problem. I would turn the van on, and my display doesn't show a light for what gear I am in. It should show park of course. It also won't let me put it into gear just as if the van is off. Rocking the van forward and back has fixed it the last few times. Specifically when I rocked the van backwards the "P" for park would light up, at which point I could also put it into gear and then the van functions normally after that. I have 104,000 miles on the van now. Anyone have ideas or theories I could test out? For now I am putting the Ebrake on every time I turn it off just incase it helps by not allowing it to move while parked.
 

·
Registered
Joined
·
58 Posts
There is opening on the steering wheel cover (it's a hole in the plastic steering wheel cover with a little cap over it) that requires your key and, when used, you can overide the shift lock. Look in your owners manual for instructions. My Honda service manual states that the problem is in the shift lock system circuit. A lengthy toubleshooting process, probably need to get a Honda service manual or CD.
 

·
Registered
Joined
·
157 Posts
I echo GLP. normally, what i'd do is
1. turn the key to ON,
2. use the override by pushing in a key
3. shift to R and back until i see P. then shift back to P
4. if it took, then leave at P and start the car.
5. if not repeat 2-4

the only permanent cure to it is when you get your tranny rebuild and they replace the Sprag bearing which tightens up the tranny again. and the shift lock should work as usual. thats what happened to mine...

CK
 

·
Registered
Joined
·
3,163 Posts
Sounds like the contacts on the range switch are gummed up. Voltage from the range sw P and N feed the p light and also unlock the shifter.
 

·
Registered
Joined
·
529 Posts
i just had this occur as well. van started but could not shift from park. also,, sliding doors would not open from key fob, dash control or door handles. used the key in the over ride procedure ontop of the steering column and shifted out of park. returned it to park and it locked up again. did same procedure a couple of more times and the problem seems to have gone away for the moment. sliding doors are working again as well. perhaps dirt and dust gumming up the switch in the column,,
any inputs folks!!
 

·
Registered
Joined
·
2,227 Posts
Most likely electrical aka battery/alternator/brake light switch/transmission range switch

If the brake light is not on when you press on the brake pedal, the shifter will not move from park. On the other hand, if the car thinks it is NOT in the park, sliding doors will NOT open.

That reminds me; anybody opened up the transmission range switch? New one is expensive ($150 for OEM!) If it can be opened, one should be able to clean it and put it back together.
 

·
Registered
Joined
·
1,486 Posts
There was a thread here somewhere on opening and cleaning that too. When I had an issue this was the first change since its easy access. I do have the old one I took out (turned out it was still good as this replace did not solve the issue). I think I ordered online for $60 2 yrs back.

Btw, this no "P" has happened quite a few times now. I just wiggle the parking lever up-down little bit and sometimes shaking the car. That gets the P light back on. But the same procedure did not work for significant other or probably was too gentle with it. When I came home from work and tried, couple of mins and back online.
 
1 - 9 of 9 Posts
Top