Honda Odyssey Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hey all. I have been searching this forum for about two weeks reading up on surging, egr and transmissions.

I have a 2004 Ody with about 75,000 on it. ( it was not listed under any recall notices for the tranny)

I noticed that when driving at a steady pace anywhere from 45-50 mph or 1500 rpm there seems to be a surging of about 200 rpms on the tachometer.

There does seem to be a noise coming from the front of the car on the drivers side.

This only happens in this range. The car always shifts smooth and fine. Also if I am speeding through that range there is no rpm surging.

Oh the sound almost sounds like static or something, its really strange. Or a strong wind blowing against the door.

Anyway look forward to some input.

David
 

·
Registered
Joined
·
665 Posts
Sounds like you have EGR port issues.
 

·
Registered
Joined
·
6,076 Posts
For the 2004 model year, it is most likely a faulty EGR valve as opposed to the ports clogging.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Everyone,
Thank you so much for the input.

I was thinking the same thing and just wanted some other opinions. I will try out a new valve this weekend and let everyone know the results.

I am a bit of a wrench head and do almost all of my own repairs. So this will be an easy change for me... Just hoping that this is all it is.

The issue is so consistent and only happens under the same exact parameters.

Thanks again.

Dave
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5 (Edited)
Quick update.

This weekend I removed the EGR valve and inspected it. It looks fairly clean.

Here is the kicker though. After I removed it I noticed that there was NO Gasket! The gasket that is supposed to be between the egr valve and the engine is non existent. ( metal to metal = very bad seal) This is what I believe is causing that crazy noise. I think that when the egr valve is opening, the vacuum is strong and actually sucking air through the non sealed connection which makes a crazy fluttering noise. ( like a vacuum leak). This would in turn mess with the mixture in the engine.( possibly causing surging)

This leads me to believe the egr was replaced or cleaned once before and the person doing the repairs forgot to replace the gasket.

I am running out tonight to get the gasket and take the car for a test drive. I will post an update afterwords.

David
What do you think?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
Update*

Replaced the gasket. Still getting the crazy fluttering noise and the rmp surge between 1300 and 1500.

This noise is like a loud flutter. Does it still sound like a bad egr? I am not getting any codes yet.

David
 

·
Registered
Joined
·
1 Posts
Same problem on 1999 Ody

David,

Did you resolve the rpm surging issue?
I have a 1999 and I have the same propblem.
Changed Egr valve (ports previously cleaned) and still doing it.

Thanks,

John
 
1 - 7 of 7 Posts
Top