Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
The first screen on startup used to have a legal message when it said all that legal stuff and then you had to press "OK" button to operate the nav. Well, the "OK" button disappeared and now I can't move past that first screen with all the legal stuff on it, it just sits there like that. I have no idea what the issue is, did anyone experience anything similar? Thanks for any help.
 

·
Super Moderator
Joined
·
13,646 Posts
Your nav system is toast. You most likely need a new NAV reader drive. Seen past posts with erratic behavior like you're describing in the dedicated NAV forum.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #3
Is that the piece where the DVD disc goes in? I just thought it would be some simple fix, like updating the disc or something. Maybe there is some software I could update or something like that? Or a reset procedure I could do?
 

·
Super Moderator
Joined
·
13,646 Posts
You can try the reset procedure. Pull the NAV system fuse or the battery for an hour. Find the NAV code and the audio system code and try that. Also check the actual disk. If it has scratches, the old NAV drives used to scratch disk too. If your disk is scratched, I still recommend a replacement NAV drive as it could be scratching the disks.

In one of the nav issue threads, a guy sent his NAV unit (the one under the driver's seat which takes the NAV DVD) for repair and they replaced the reader and it wasnt terribly expensive but I don't remember the price.
 
1 - 4 of 4 Posts
Top