Honda Odyssey Forum banner

21 - 25 of 25 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter · #22 ·
Clicking with a charged battery could mean an issue with the starter. Try banging the starter to see if it engages.
Thanks. I am able to boost but battery doesn't get fully charged for restart. I think the trickle charger is also caput :-(.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #23 ·
Any advice on post #17 will be appreciated!

Also, when I was changing PS fluid made a mess. Oil on alternator (seems to be fine). Bit of oil on the drive belt and alternator pulley. Cleaned it up with shop towels to the extent possible. Guess this should be fine.
 

·
Registered
Joined
·
9,434 Posts
Bit of oil on the drive belt and alternator pulley.
If any oil got on the belt's drive surface, replace the belt. Clean the pulleys with brake cleaner.

A contaminated belt could slip, overheat, and cause electrical etc. problems.

Also, the oil will eat the rubber in the belt so it won't last a full term anyway. Edit: It was PS fluid, so no belt deterioration will occur. If engine oil, it would.
 

·
Registered
Joined
·
150 Posts
Discussion Starter · #25 ·
If any oil got on the belt's drive surface, replace the belt. Clean the pulleys with brake cleaner.

A contaminated belt could slip, overheat, and cause electrical etc. problems.

Also, the oil will eat the rubber in the belt so it won't last a full term anyway. Edit: It was PS fluid, so no belt deterioration will occur. If engine oil, it would.
Thanks Dave! Have a blessed weekend!
 
21 - 25 of 25 Posts
Top