Honda Odyssey Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Upon startup the following warning lights are shown.....

1. Check brake system
2. Check TPMS system
3. Check ABS system
4. Check VSA system
5. Check airbag system

Other issues include....
high beams ONLY, windshield wipers only work on one speed, alarm will not arm, doors will unlock but not lock from key fob, gauges will light up but do not give readings, slide doors will not open while van is running and turn signals do not work. Van will start and drives fine.

Most common referred to TSB has been checked and no issues. Van has been pulled apart checking for leaks but no significant damaging leak found. Still need to remove corrosion from negative battery terminal, and multiplex has been replaced. At the point of looking for a ground that connect all of these functions but do not have access to a wiring diagram currently. Any help would be greatly appreciated!!
 

·
Registered
Joined
·
1,523 Posts
At the point of looking for a ground that connect all of these functions but do not have access to a wiring diagram currently.
Perhaps this link will help. It's a sticky on the first page of this forum.

 

·
Registered
Joined
·
2,248 Posts
Did all of these problem onset at once, or has it been slowly degrading to current state?
When you said turn signals do not work, do you mean front or rear or both?
I wrote up a DIY for front right turn signal repair,
It involves a grounding point G201, which combines 5 separate grounding circuits, there is a similar grounding point on left front.

Beyond that, you will likely need professional help, unless you know how to read and troubleshoot electrical circuits.
 

·
Registered
Joined
·
129 Posts
How old is the battery? You mentioned the neg batt terminal is dirty, I'd start there. Poor connections or a crappy battery does weird stuff to these vans.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Any thought on switching out the drivers side MICU, anyone?
Maxud my husband is an electrician and mechanic so he can definitely read and troubleshoot wiring diagrams....we just have been trying to exhaust all routes before having to purchase one.....google photos have actually been quite useful! Tduck, we messed with the battery the other night....replaced all wiring and removed any lingering corrosion. Unfortunately this did nothing....we are now looking at either the MICU or PCM as the culprit.
 

·
Registered
Joined
·
2,248 Posts
Maxud my husband is an electrician and mechanic so he can definitely read and troubleshoot wiring diagrams....we just have been trying to exhaust all routes before having to purchase one.....google photos have actually been quite useful! Tduck, we messed with the battery the other night....replaced all wiring and removed any lingering corrosion. Unfortunately this did nothing....we are now looking at either the MICU or PCM as the culprit.
ok, but you did not answer my question.
Also, if he is an electrician, whats the signal bulb missing? Signal or ground.
 
1 - 7 of 7 Posts
Top