Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Our van's windshield washer fluid is not working. Check the Fuse it is OK. Yesterday check the voltage at washer connector but there is no voltage when the washer fluid switch turn ON. Manual says to trouble shoot for the relay in the underhood fuse box. Does anybody know which relay # is that. Also if relay is OK then it can be faulty combination switch.

Did somebody has replaced this switch ? Looking at the service manual it tells you to remove the steering wheel before you take the covers off which located around the switch. Is it true ?? Looks like I can remove the covers ok without taking steering column out.

Please reply, because of the weather I have to tackle this issue in next day or two.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
Our van's windshield washer fluid is not working. Check the Fuse it is OK. Yesterday check the voltage at washer connector but there is no voltage when the washer fluid switch turn ON. Manual says to trouble shoot for the relay in the underhood fuse box. Does anybody know which relay # is that. Also if relay is OK then it can be faulty combination switch.

Does anybody have diagram of the circuit ? Please PM me
 

·
Registered
Joined
·
157 Posts
By chance did you check hose from reservoir to nozzle under hood? I had problem with washer fluid on 05 Honda Odyssey, it turned out to be the hose had disintegrated by corner. Might be worth second look.
 
1 - 5 of 5 Posts
Top