Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
Hello all.

I have been having a problem with the factory Nav system in the last couple weeks. It does not happen every time I start the van, but it is becoming an irritation. When I start the van, the Nav screen boots... goes to the disclosure screen and will not register my pushing OK on the screen. After the screen times out/goes blank... It will not allow me to use any of the buttons around the screen. If I put the van in reverse, the backup camera will come on. There are no buttons I can press to activate the screen, I have to restart the van to hopefully bring the display back up. The battery has not been disconnected recently and I have not messed with the Nav disc/drive at all either. This seems to be happening more and more now that the temperature is climbing... We are expecting to reach almost 100 degrees by tomorrow and Saturday.

If you have any suggestions, I am all ears. I did search the forums and on google for this problem and there is no record of anyone having an issue like this and to make sure I wasn't posting a previous issue that has been covered. If I did, I do apologize in advance.

Thanks, Tim
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #2 ·
Has anyone experienced this problem before? I would like to be able to pinpoint the problem before bringing it into the dealer to be diagnosed....Any and all help is appreciated.
 

·
Super Moderator
Joined
·
13,875 Posts
I don't remember this one before but I do remember odd behavior when the NAV Unit is going out. Can you eject the disk and see if its scratched up? If it isn't the NAV unit might be going out given that the camera works fine but that's just a hunch.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 ·
I don't remember this one before but I do remember odd behavior when the NAV Unit is going out. Can you eject the disk and see if its scratched up? If it isn't the NAV unit might be going out given that the camera works fine but that's just a hunch.
I will check the disc for scratches and report back. Hopefully it isn't the NAV unit, cause that will suck.
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #5 ·
Update... The Navigation disc is in great shape, no scratches or gouges. There wasn't even a spec of dust on the disc. My local dealer is a lil concerned and didn't even have a suggestion as to the failure point.
 
1 - 5 of 5 Posts
Top