Honda Odyssey Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Any advice. I have had the van for 4 years. It has been 100% consistent the entire time. Doesn't get better or worse. Drives fine, just multiple comments from passengers that it doesn't feel right. Sometimes when letting off accelerator, it feels like a manual trans that I did put the clutch in quick enough when letting off accelerator, like its holding onto gear. Also when shifting it is a bit hard. I have done two transmission services and replaced motor mounts. All helped but didn't solve. Anyone have any advice?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
You changed all five motor mounts?

Check the suspension for worn out components such as the lower control arm.
Not suspension, I have changed control arms. I changed the motor mounts that are outrageously expensive because of cylinder deactivation. I did not know there were 5....
 

·
Registered
Joined
·
274 Posts
How many miles are on the van? Have you changed the 2nd and 3rd gear switches on the tranny yet?

There's plenty on the forum re harsh upshifting and delayed downshifts symptoms tied to these 2 switches.

I change mine every 150k miles. Use only Honda oem switches.

Sent from my SM-N910V using Tapatalk
 

·
Registered
Joined
·
97 Posts
We have an 2005 Honda Odyssey. Can someone help us with the part number or the part description of what ccervenka referenced above? I cannot seem to find gear switch part or video on how to replace these parts. I found pressure switch which is like sensors on one end and electrical on the other end. Parts numbers are below. Are these the ones that he referenced? There are only two of these in total in the transmission, correct?

28600-RKE-004
Switch Assy., AT Oil Pressure

28610-RKE-004
Switch Assy., AT Oil Pressure (WASHIMIYA)

90471-PW7-A00
Gasket (10MM)
 

·
Registered
Joined
·
423 Posts
Here are the parts:
https://www.bernardiparts.com/Honda/Parts-List.aspx?year=36&product=11&door=3&grade=126&transmission=7&area=2&section=3&assembly=13129

152832

My transmission is showing similar symptoms, it occasionally violently jerks while going downhill and braking. I checked some of the older posts and I have not seen anybody claiming that replacing the solenoid valve A & B or one of the pressure switches will fix the issue. I pulled all solenoids 2 years ago and they all tested out fine (resistance within spec and working when connected to 12v).

Throwing parts at this issue can become costly very quickly but if you are willing to do it let us know what you find.
 
1 - 6 of 6 Posts
Top