Honda Odyssey Forum banner

2007 new noises from engine and driveline

931 Views 9 Replies 5 Participants Last post by  devOps88
Recently my 2007 has started making two new noises. Can you speculate as to what they might be?

(1) When going up a hill under 30kph/20mph with a cold engine, there's some type of vibration coming from either the transmission or the driveshaft. It lasts only briefly, under 5 seconds. The best I can describe the sound is small metal pellets being shaken in a tiny tin can.

(2) The engine is making a higher pitched sound than it formerly did. This is regardless of temperature or other operating conditions. The droning noise varies in pitch with RPM. It sounds like a mechanical fan clutch somewhere has failed, resulting in a fan which spins linearly proportionate to current RPM.

The van is driving fine. There are no other noticeable symptoms of the problem(s) causing these two noises.
I have a Foxwell scan tool loaded with Honda software available for debugging.

TYIA.
1 - 10 of 10 Posts

· Registered
Joined
·
30 Posts
Discussion Starter · #2 ·
I think (1) is this issue:
The steps to reproduce my issue are nearly identical to what's described there
 

· Registered
Joined
·
96 Posts
Recently my 2007 has started making two new noises. Can you speculate as to what they might be?

(1) When going up a hill under 30kph/20mph with a cold engine, there's some type of vibration coming from either the transmission or the driveshaft. It lasts only briefly, under 5 seconds. The best I can describe the sound is small metal pellets being shaken in a tiny tin can.

(2) The engine is making a higher pitched sound than it formerly did. This is regardless of temperature or other operating conditions. The droning noise varies in pitch with RPM. It sounds like a mechanical fan clutch somewhere has failed, resulting in a fan which spins linearly proportionate to current RPM.

The van is driving fine. There are no other noticeable symptoms of the problem(s) causing these two noises.
I have a Foxwell scan tool loaded with Honda software available for debugging.

TYIA.
My 2007 had similar sounds. It ended up being the heatshields. I used a SS hoseclamp, and it's silent now!
 

· Registered
Joined
·
30 Posts
Discussion Starter · #7 ·
For 2, have you checked the alternator? Sometimes a failing voltage regulator will make a whining sound correlated to RPM.
Alternator was the root cause. The voltage coming out of it was steady without a substantive AC component, so I was surprised.

I had a shop do the replacement for $600 USD all-in because lazy.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top