Honda Odyssey Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello guys,
This past week my 08 Honda Odyssey touring threw the p3497 code. I've done some research and checked my oil levels which was low and topped it off for now, will do oil change soon (probably burning oil). I installed two new oil pressure switch front/rear reset the code and turned on the engine, received same result with week idel/weak engine and within 30 seconds the same code comes back on. I installed both old oil pressure sensor switch back as I thought those may not be the issue and went to sleep. This morning before going to work I turned on the engine and everything seemed fine, no rough idle/weak engine. It seems to be temperature caused? Will software update help? Any help is appreciated. I will be checking it again after work.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
So I cleared the code and installed the two new oil pressure switch, drove the van for around 10 miles. P3497 came back on after the engine warmed up again. Any suggestions?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I've read some post and visited the vcm tuner site. Will disabling the vcm with vcm tuner help with the code?
 

·
Registered
Joined
·
10,819 Posts
It's a problem with valve pause system on bank 2 (front bank) so there's no reason to do anything with the rear bank at all. Installing a VCMTunerII might mask it but, personally, I'd get to the bottom of it before masking the issue with the VCMTuner.

If it were me, the first thing I'd do is change the oil, make sure you're using a good quality 5w-20 synthetic and an OEM Honda filter. Then I'd start chasing the problem if the code still returns.
 

·
Registered
Joined
·
10,819 Posts
Ok. Will do a full oil change tonight and follow up here.
Be sure and use an OEM filter. The OEM filter recommendation isn't because they are the best at this or that but because they are the known good and a baseline for starting a diagnosis. I have cured these valve pause codes before by just changing the oil and filter. Often I've found a cheap quick/jiffy lube filter on them. Those places buy filters for $0.50 and sell them for $5. They also use the cheapest bulk oil that can be bought.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
Went to Honda dealer and got the 15400-RTA-003 oil filter and honda 5w-20 fully synthetic oil, changed the oil and added back 4.5qt. drove for around 7 miles and the same code came back on after the engine warmed up. No clue what to do next.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8 (Edited)
Could it be the variable valve timing solenoid or electrical wiring to the front oil pressure switch? Also could anyone explain why the code only pops when when the engine warms up? Is it the temperature that makes the vcm shut down the 3 cylinders?
 

·
Registered
Joined
·
1 Posts
245K 08 Odyssey - i have the same code. I have an oil leak around the VTEC selenoid. I dont know where the leak is from yet, (valve cover next to the selenoid or ...) but assumed the gaskets. I replaced both, then i got this message. I still have an oil leak. I will work on it this weekend.
 

·
Registered
Joined
·
383 Posts
Be sure to check your engine oil level frequently if you are still having this issue. Has to do with VCM. Follow John Clark's recommendations
 

·
Registered
Joined
·
38 Posts
I'm having almost the exact the same issue as lyndonvang, did you figure this out? I can drive around local streets as much as want without issue but when I get on the highway P3497 appears. If I let it cool down all is good.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
Try this. There is a spool Valve in the rear of the engine, I've circled the connector in blue. Put 12v from the battery to it a couple of times and you will hear it clicks. I did this and it has been going good so far for around 800 miles. Hope this helps.
 

Attachments

·
Registered
Joined
·
6 Posts
I had same problem on my 2008 ODY w 129,000.
There are several areas to investigate:

software update from dealer, loose/corroded ground wire strap (i cleaned ground wire on the very front of vehicle just under plastic shroud)
spark plugs, &
name brand full synthetic oil w OEM filter.

3497 has gone out and fully cleared from system.

I am getting the max muzzler today from maxud on the ODY forum. I aim to install it as a preventative measure as I don’t want the ECO light and VCM kicking in all the time.

Hope this helps!
 
1 - 14 of 14 Posts
About this Discussion
13 Replies
6 Participants
Hevvykevvy
Honda Odyssey Forum
Odyclub community is the #1 forum to discuss all things Honda Odyssey: minivans, safety, service maintenance, mods, and more.
Full Forum Listing
Top