Honda Odyssey Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
My 2010 Touring edition blows air fine, and the temperature is good...but it will only blow through the main vents (won't switch to defrost or floor). I have seen posts regarding the mode actuator motor. I just have a couple of questions:

  1. Is the mode actuator located on the passenger side, or the driver's side?
  2. Is the part number for the mode actuator the same as the blend actuator...or are the units different?
  3. For anyone who has done this...what all has to be removed to access the actuator motor screws?
Thanks in advance...
 

·
Registered
Joined
·
203 Posts
Mode motor is on passenger side, between the glove box (you need to remove it first) and the center HVAC unit.
 

·
Registered
Joined
·
43 Posts
I’m struggling with the same exact problem on my 2009. Even after removing the glove box, the screws are very difficult to reach. And I haven’t located a replacement part. My part is an AW063800-1500. Please let me know if you have any luck because the van goes into the shop on Friday if I can’t get this fixed.
 

·
Registered
Joined
·
43 Posts
It doesn’t look like a generic replacement part exists. I have found the Honda OEM part for $100. I think it’s possible to buy a generic part with the same motor but different pin configuration and simply swap out the motors, but this is getting pretty geeky. I’d at least try to pull the existing part, open it up, and see if I can clean it up to get it working again, but so far I can’t even get it out.
 
1 - 6 of 6 Posts
Top