Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2011 Odyssey - No power to Navi/Radio after ignition

Hi, I was wondering if anyone had a similar issue.... for the first time yesterday, as I turned the ignition on, the power to the navi and radio/DVD system disappeared. The power would come back after the ignition is turned off, idled for like a good 5 minutes or so, and turned on again (granted this did not happen every time when I turn on the ignition, there were times when everything just came out normal.) However, this morning the same problem happened again, but this time the power to both the navi and radio/DVD system "came back on" by itself while the car was still running....and was fine every since......
Not sure what exactly is causing this to happen...a little hesitant to take the car to the dealer since I know this would never happen in front of them....
Thank you for your time!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Hi, I was wondering if anyone had a similar situation; for three mornings in a row, the NAVI and the radio/DVD system on my van would not power on when the ignition is started. The "system" would remain "powerless" for the most part while the van is being driven, then at the brink of an eye, power is restored. This also occurs when the van is turned off, idled for a few minutes, and turned on again. Now, the problem with the power source happens in the morning (at cold start) and in the evening when I go pick up the car from the parking lot after work. Could this be a problem with the fuse? the wiring? battery connection?
Thank you!
 

·
Registered
Joined
·
359 Posts
see if your VIN number is part of this service bulletin:
http://www.urvi.net/forumfiles/SB/A11-022.PDF

Ours was. I only noticed the blank screen one time after starting the van. I turned the van off and then restarted and the navi screen turned on. I had the van at our dealer for some other work and I mentioned this issue too and they replaced the navi screen as per the service bulletin.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thank you Steve. This is useful. Unfortunately our VIN is included in this service bulletin. I actually took the car to the dealer this morning and they asked me to have it parked there overnight so they could "cold start" the car the next morning (since I mentioned this only happens in the morning or if the car's been parked for a long period of time)....in your case, did the radio or DVD work?
 

·
Super Moderator
Joined
·
13,646 Posts
Moved and merged your threads in the dedicated audio/video/Nav forum.

Please post threads in correct forums to prevent thread locks.
 
1 - 5 of 5 Posts
Top