Honda Odyssey Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hello,

I bought 2012 EX-L (no navi, no RES) two weeks ago and drove over 200 miles in that time. Last night when I got off work and start the car, the information display didn't work. It turned into a white screen with a few black lines. It lasted like that for a good 45 minutes. Once I got home and turned off the car and started it again, everything was normal.

I called my dealer and he talked with the service guys but they said that they never heard about this issue and cannot fix it if they cannot see it. There must be something wrong, otherwise this should not had happened.

Has anyone noticed an abnormality like this?

Thanks.
 

·
Registered
Joined
·
884 Posts
I have about 2500 miles on my 2011 EXL res and have never seen what you describe although I have noted several soft ware issues. You say it resolved when you restarted after 45 minutes. If it happens again try a restart right away. If it persists I'd take some video of it when it's in progress and insist that the unit be replaced.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Good idea robie. I'll make a video of that if it happens again. There must be something wrong otherwise it wouldn't had happened. Maybe there is a loose connection.
 

·
Registered
Joined
·
884 Posts
I think there was a loose connection in whoever wrote the software for the Bluetooth phone. Best of luck. Hope it was a one off.
 

·
Registered
Joined
·
29 Posts
Same exact issue with 2011 and Nav. Dealer cannot duplicate. Showed pictures and video of phone. Since they cannot duplicate it they cannot fix it. Sucks. $40k for the van and it makes me sick to see this. They make absolutely no effort to repair or replace because they cannot duplicate. Looks like you have to go further up the food chain to get this one fixed.
 

·
Registered
Joined
·
45 Posts
If it's bothersome enough, you can get them to update the firmware? If Honda can do such a thing? If not I'm sure you are within your bumper to bumper coverage so raise hell until they swap out that the troublesome unit. Best to make a scene in the lobby area where all the customers are hanging out and waiting to close deals. ;)
 

·
Registered
Joined
·
3,292 Posts
Same exact issue with 2011 and Nav. Dealer cannot duplicate. Showed pictures and video of phone. Since they cannot duplicate it they cannot fix it. Sucks. $40k for the van and it makes me sick to see this. They make absolutely no effort to repair or replace because they cannot duplicate. Looks like you have to go further up the food chain to get this one fixed.
Have you seen tsb 11-022 by any chance?

As per a similar problem with a van with no navigation, the display unit is not the same, so it could be a different issue alltogether unfortunately

http://www.odyclub.com/forums/54-20...onda-odyssey-technical-service-bulletins.html
 
1 - 8 of 8 Posts
Top