Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
606 Posts
Discussion Starter #1
Anyone have an issue with the HVAC or A/C display cutting out?

OK, was driving yesterday admiring my new brake install when I did a 90 deg. left turn, and the HVAC display went blank and the fan cut off, then 2 seconds later comes back on like nothing happened. I did not have AC on just vent BTW, but the fan was blowing enough to hear it. This happened twice within about 5 min of each other.

The other displays and dash lights did not cut out, and no DTC's. The AC has worked flawlessly since driving kids to practice and back, making 90 deg left turns, but I'm stumped as to what happened.

I'm assuming its a connection thing, and maybe battery or alternator related, it may shut down if it doesn't have enough power? I'm going to check battery connections (although I just greased them and they looked very clean) and the battery tie down to see if maybe that's moving in the turn. I'm also experiencing a accessory item noise (goes away if you run w/o belt) and its not the PS pump, seems like it might be the alternator. This is just additional information.

Anyone want to buy my '06 ex-l, beginning to wonder why we bought this darn thing. :mad:
 

·
Registered
Joined
·
444 Posts
**Off Topic**

On your silhouette, did you ever have to replace the coolant intake manifold gasket? Our 98 silhouette ran like a champ, until that was done, and the ensuing head gasket leak...
 

·
Registered
Joined
·
606 Posts
Discussion Starter #3
Yep, had the intake manifold gasket replaced at roughly....85k? Been holding since. Been a good van.
 

·
Registered
Joined
·
606 Posts
Discussion Starter #4
Oh and to close this threat out, the left turn was I guess somewhat just by chance, as the part that failed was the "thermal cut out" and I have a posting about how to change it elsewhere on this forum, a $.40 part instead of replacing the whole blower transistor unit at about $75 or whatever it was.
 
1 - 4 of 4 Posts
Top