Honda Odyssey Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Good Morning,

I have a 99 Odyssey with 240k.

I can always tell when the AC compressor engages because one of the fans at the front of the engine also engages at the same time.

If it's only fairly warm out and the van has been kept in the garage, it will run and cool just fine. The compressor comes on and stays on.

However, if it is hot out and the van has been parked outside in the sun, the compressor doesn't want to engage. The fan and compressor will come on for a second, then shut off. It continues to repeat this every couple seconds. However, when the van is cool, the compressor will come on and stay on.

Now when the van is moving and these short startup/shutdowns occur, I have real problems.

It happened yesterday when I cranked the AC to max while traveling at about 50mph. When the compressor tried to engage, it almost yanked the engine to a stop. The "Maintenance Required" light came on and one other green light that I couldn't read fast enough.

As soon as I shut the AC off, everything was find and the lights went out.

The system has the correct amount of 134a in it.

Any thoughts?

Thank you.
 

·
Registered
Joined
·
253 Posts
The system has the correct amount of 134a in it.
How do you know it has the correct amount? Short cycling as you described can be caused by too much or too little refrigerant.

If it is overcharged it could add a high load on the engine when the car is at speed, but the high pressure switch should kick in and shut it off promptly.

EDIT:
Just read your last post. Looks like William Wiles has answered your question. Your system IS overcharged.

http://www.odyclub.com/forums/24-1999-2004-odyssey/149879-fan-kicks-everytime-ac.html#post685429
 
1 - 3 of 3 Posts
Top