Honda Odyssey Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
If so, where did they connect the wiring for the hitch? I spent some time this past weekend trying to remove the hitch wiring that was installed by Uhaul in an effort to troubleshoot some problems I've been having with my left turn signal.

I originally thought the wiring would be plugged into the factory hitch port behind the rear passenger side panel. But there was nothing connected to the port when I checked so now I have no idea where they connected their wiring.

The wiring seems to originate from the rear driver side light assembly but without removing the rear bumper, I can't follow it.
 

·
Registered
Joined
·
82 Posts
When I bought my 2005 used it already had the hitch, yes U-Haul. The wire comes from the rear left light assembly and was dangling into the trunk pit. Is it your case too? I wanted to remove it as I don't have any boat nor planning any haul in any near future so far. But when I opened the light assembly I found that the wires connected with the ones that come to the light bulbs, so neat - I wouldn't want to destroy that good work. So I just rolled the whole cord up into a coil-like loop and hid it under the light assembly. Who knows, the plans can change anytime.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I'm not sure where the hitch wiring on mine connects to. It goes into the paneling in the rear cargo area on the driver side but I removed the rear light assembly and didn't see any wires there. It apparently connects somewhere behind the bumper so without taking the bumper off, there's no way to trace it.

I'm suspecting it's spliced into the wiring for the rear driver side lights and it's the turn signals on that side that aren't working.
 
1 - 3 of 3 Posts
Top