Honda Odyssey Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a '03 EX-L. It has the front/rear DVD sound system. The issue is on the display it shows that the radio is on, the volume goes up and down, it switches to CD/DVD, AUX, and AM/FM. However no sound comes out of any of the speakers in any of the modes. The DVD displays on the overhead screen but no sound. Also, the volume/audio control on the steering wheel does not work either. Any thoughts? Thank you.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
I took the radio apart and found a penny inside the radio, not the cd slot. The penny was inside where all the circuit boards are. I re-installed the radio and still no sound from the speakers. Everything is showing that it works, AM/FM, CD, DVD. just no sound.

My question is in the back of the unit there are 4 wire harness receptors, 2 gray and 2 Lt. blue. However there are only three wiring harness plugs, 2 gray and 1 Lt. blue. What is the 4th receptor (Lt. blue) for? Why is there nothing plugged into it?

Is there an amplifier between the speakers and the radio? Or does the speakers run straight to the radio? If there is an amplifier where is it? And can that have gone bad?

My other concern is the steering wheel control. The volume/audio controls don't work. The cruise controls on the steering wheel work but not the audio controls. Any thoughts as to why they don't work?
 

·
Registered
Joined
·
76 Posts
It sounds like the internal amp in the radio is blown, which is certainly possible if there was a penny inside on the boards. There's no way to know what was shorted to what with the coin kicking around in there and it's very easy to believe that one or more components was cooked.
 
1 - 3 of 3 Posts
Top