Honda Odyssey Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
HELP!!!
There is a whining noise that comes from my blower motor under the glove box.
I want to pull the blower out to look for any debris, but the screws in the back for the little cover, and the blower are stuck.
Any advice?
 

·
Registered
Joined
·
60 Posts
I did this a couple of weeks ago... Ordered a blower from ebay to replace mine because was making a ticking noise.

There are 3 screws. one of them is a bit hard to get to but I did it by laying on my back on the passenger side floor. I just used a phillips head but I think you can use a 10mm socket too if it's on tight...

You don't need to take out the small round cover - you can do that once the blower is out.

The wiring clip wasn't sliding out easily so I used a pair of small pliers to gently pull the clip out. Make sure you don't force it too much or it'll break... You can tell how the clip is installed by looking at the new clip on your new blower motor.

Should take all of 15 minutes to do... No need to remove the glovebox either.
 

·
Registered
Joined
·
613 Posts
dbx said:
I did this a couple of weeks ago... Ordered a blower from ebay to replace mine because was making a ticking noise.
many times this is a leaf caught in the blower cage...did you find anything wrong with the blower you removed? I assume it solved the problem? Interesting.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I haven't tried removing the blower again.
dbx offered some advice on how to get the blower removed, because I couldn't get the backside screw loosened.
I will let you all know how it turns out.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I got the blower removed using an 8mm socket and found a small leaf inside it. Removed the leaf and everything is fine again.

Thank you all for your help.
 

·
Registered
Joined
·
525 Posts
yup,, had the same problem. blower was making a droning noise at higher speeds from a leaf that was caught in the squirrel cage. three screws out,, back one was a challenge but with the assistance of a universal joint and a 5/16 or 8 mil socket it came out.
also blew compressed air thu the entire area to remove any other debris and clean the filter as well. just a note on this,, while you have the fan and squirrel cage out, why not clean that too.. cage is easily removed from the motor shaft and the fan motor from the housing.. mine had plenty of black dust (probably from carbon brushes). all blown out with compressed air.. happy to say all reinstalled and working silently again. whole process completed in less than two hrs.
to all,, thanks for the info.
pete
 

·
Registered
Joined
·
151 Posts
I must be missing something. I've got the front two screws removed and a "rear" screw. All 8mm hex. but I can not get the blower to come out. It still seems to be connected at the rear. For the life of me, I can't see another screw. 2004 Odyssey.
 

·
Registered
Joined
·
1 Posts
Hi Smedley! I'm having the same experience. It still seems to be connected at the rear. You say "Found it." what was "it" please share with the forum.
A+
 
1 - 10 of 10 Posts
Top