Honda Odyssey Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone, this is my first post on this forum. We have a 2018 Odyssey Elite, picked up in June 2017. We are having a couple of issues with our Blu ray player that I cannot seem to figure out.

1. When we insert a disc, the Nav screen says that it is "Loading..." and never changes. However if you watch the screen in the second row, it will load the movie and then begin playing it.
2. When the movie starts playing, it will only play sound through the headphones. We cannot get it to play sound through the car speakers. Cannot find a way to get it to play sound through the speakers.

We have taken car to dealer and they could not tell me how to fi. I have also called the Honda Corporate line and they have not been able to help either.

I tried searching for issues similar to mine but I did not find any. Hopefully somebody can tell me if they have experienced this issue.
 

·
Registered
Joined
·
5 Posts
I just bought a 2018 Elite and am having this exact same issue. Did you ever find a solution? I’m taking it in to Honda tomorrow. Thank you for any insight!
 

·
Registered
Joined
·
28 Posts
No answer, just speculation... My RES is rebooting independently from the head-unit in the front dash. Sounds to me like some issue with communication between the 2 systems. I'd check the wiring between the RES and the unit in the dash. Probably a loose connector, wire short, etc.
 

·
Registered
Joined
·
28 Posts
Fingers crossed for you! I will be calling the service dept of my dealer tomorrow to set up an Appt for our own RES issue. Let us know how it goes.
 

·
Registered
Joined
·
884 Posts
I’m assuming if you called Honda tech they walked you through all the software settings to make sure it is set up right? In my own experience there’s a ghost in my 2018 Canadian version of Elite that can change my settings even when I know they were set right.

The first week of ownership my infotainment system had to be replaced. I’ve had no issues with my Blu Ray whatsoever despite the many other non related software issues I grapple with.
 

·
Registered
Joined
·
5 Posts
So I had called and asked if I needed an appointment and they said no, just bring it in whenever. So I go in today and he says you need an appointment...going back tomorrow.
 

·
Registered
Joined
·
5 Posts
Honda had my van for 2 days and they have no idea how to fix the issue. They say they’ve never seen it before. Their district manager is coming to visit tomorrow and they plan on running it by him or her and searching for answers. Service manager was extremely nice to me, however, I hope this issue gets resolved. I also wish the OP would comment as I’m still wondering what their outcome was.
 

·
Registered
Joined
·
28 Posts
Fingers crossed for you. Sounds like an issue with a wiring harness between the RES and the front head unit (assuming your back speakers work with radio / other sources).

I am waiting for a new RES control unit to come in; hopefully that fixes mine.
 

·
Registered
Joined
·
5 Posts
Evandy, I hope you’re having more luck than me.
No call back from Honda yesterday. I just called and spoke with someone who is leaving a message for the service manager to return my call. This is disappointing.
 

·
Registered
Joined
·
28 Posts
Details over in my thread, but part installed and all looks well after a short drive. Need to take some longer ones to know for sure.
 

·
Registered
Joined
·
2 Posts
On Sunday, my kids were watching a blu-ray movie while my wife was in the store and we sat in the parking lot. I scrolled through the Infotainment screen and noticed that a software update was available. Since I have the ATT hotspot, conducting the update via wifi was an option for me. The update stated it was successful. However, since the entire infotainment system rebooted after the update, my Blu Ray player no longer works. Whenever I put in a DVD, it just says "LOADING" for about 20 seconds and then goes to "Error" at the top of the front screen. Everything else seems fine, but just the Blu Ray player no longer works.

I called Tech support on Monday am. I explained that I tried reloading the software update and did a factor default reset. They referred me to the dealership.

I took the van to the dealership this am and after 2 hours, they tell me that my Blu Ray player is bad. I asked how/why it could have been working at the time I initiated the software update to broken after the update!?!? To add insult to injury, they quoted me $659 before tax to replace it since I am 10k miles over my warranty. $659 for a Blu Ray player!!!

Frustrated, I called Honda tech support back and argued my case. They switched me from the warranty department to the products and services department. She had me ask the service tech what caused the failure. Then it got weird. American Honda wanted them to say it was a manufactures defect, but the service manager didn't want to say that for some reason. I mean, it sure wasn't like it was due to my abuse or neglect. They just kept saying, "It has power, but it's dead", "It's no good". I asked, "Is it a manufacturers defect?" They would just reply, "I dunno, it is made by Panasonic." I don't know how the manufacturer/dealer reimbursements work, but it was an awkward situation with me in the middle of it while on the phone. I just pleaded that, regardless of who its made by, or the status of my 36k warranty, a $659 DVD player replacement should be covered on a $42k vehicle when it was the software update that jacked this thing up! ....literally watching it one minute and broken the next??? Not coincidence!

An American Honda case manager is supposed to get back with me within a day or so. I'll post my outcome, but better believe I'll be making my first ever YouTube review of this if they don't stand by it. I'd love to hear about any similar experiences.
 
1 - 12 of 12 Posts
Top