Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I am having an extremely strange problem. There is a brief chirp coming from passenger side front of the vehicle which is accompanied with a momentary loss of power. It occurs under light throttle and occurs more reliably when going up a slight grade. It does not seem to have to do with the weather-ie rain. About a year ago, I had the tranny refresh and service for the judder. Approx 52k miles. Video captures it- note the flicker in the tach when it occurs. Any thoughts on what it may be would be appreciated.
 

·
Registered
Joined
·
508 Posts
It could be a trans solenoid issue. I've seem a few people mention that but, I'm not saying that this is what is wrong with yours. Ive seen a few mention that they had honda replace the external control module under factory warranty & updated trans. code. Fixed shift clunk & hesitation problems too

Sent from my SM-N976V using Tapatalk
 

·
Registered
2015 Honda Odyssey EXL
Joined
·
12 Posts
Good Evening. I am having the EXACT SAME sound/issue with my 2015 EXL with almost identical milage. Did you ever figure out the cause of your sound or resolve it? Thank you!
 

·
Registered
2015 Honda Odyssey EXL
Joined
·
12 Posts
external control module under factory warranty & updated trans. code
OdysseyMan1223,

Would you mind elaborating on these issues? I'm new here and trying to get to the bottom of what issues our particular model may be having (or potentially encounter in the future)

Thanks
 

·
Registered
2015 Honda Odyssey EXL
Joined
·
12 Posts
Adding the video of our 2015EX-L to this thread in hopes of someone chiming in on what this might be. You can hear the chirp noise at the 4 second mark of this video. Thanks!

 
1 - 5 of 5 Posts
Top