Honda Odyssey Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I own a 1998 Honda Odyssey with about 200,000 miles on the odometer with an engine rebuild last year.

The last month, after I park the van in the garage, fluid starts running/dripping, creating a fairly big puddle in the garage, about 18"diameter. It comes from the middle of the engine, slightly to the passenger side. When I turn off the engine and get out of the van, it smells bad, like rotten eggs, and fluid just starts running and then dripping after two minutes or so. When I start the engine again, it stops dripping.

I took the van to the shop last week, and after performing a high pressure test, they detected a leak in the by pass valve hose and a small leak in the radiator. Both of them were replaced, and I thought the problem was solved. I drove the car quite a long distance, it was fine, until today. Got home, it smelled bad again, and this fluid was running again from under the engine. It has no color (clear), and when I opened the coolant reservoir next to the radiator, it has the same smell. The coolant level is just slightly lower after what I thought was a major leak.

Any idea, suggestion from readers here would be appreciated. I certainly would like to keep the van, that is until Honda imports the smaller than the current Odysseys to the US. Just got back from Asia, and love the JDM Odysseys there.

Thanks in advance.

Tim
 

·
Registered
Joined
·
249 Posts
I have a 95 Accord that use just about the same radiator my Ody does. I had a similar problem you mentioned.

What happened is the rubber O-Ring that seats the radiator drain valve was not put on square and cracked. This caused a small leak that when driving will blow onto the motor and hit the header and makes a burning smell. Its an easy fix hope yours is equally as easy.

Source where your leak is. Clean off the motor and look to see where fresh coolant is.
 
1 - 2 of 2 Posts
Top