Honda Odyssey Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
Between myself and the dealer, the service listed below was done last week and just tonight I noticed that the cruise control is dead (no light on button, no light cruise control indicator on dash and actual cruise doesn't work). Any link between any of this service and the problem or just a freaky coincidence?

1) replaced rear brake pads (me)
2) replaced brake fluid (dealer)
3) did 2 drain & fills of the transmission fluid (filling through the fill plug): note there was a black plug with multiple wires just above the fill plug that I disconnected and reconnected each time to get easier access to put a funnel in the fill hole. (me)
4) changed engine oil/filter (me)
5) changed engine air filter (me)
6) changed cabin air filter (me)
7) replaced 2-way valve (17371-S0X-A02), solenoid valve (17012-S10-L01) and gas cap to resolve P1457 code (dealer)

Nick
 

·
Super Moderator
Joined
·
13,702 Posts
Check the engine bay to see if they forgot to connect any connectors perhaps?
 

·
Registered
Joined
·
19 Posts
you surely have tried toggling the main switch itself?

then it can only be one reason: the switch itself is broken. the light on the switch, is very simply connected to fuse 6 through the main switch. if the fuse is not blown, then the main switch must be not connecting.
 

Attachments

·
Registered
Joined
·
6,074 Posts
Before troubleshooting.
– check that the speedometer works properly.
– check the No. 9 (10A) and No. 6 (15A) fuses in the Driver’s Under-Dash Fuse/Relay Box, and No. 47 (20A) fuse in the Under-Hood Fuse/Relay Box.
– check that the horn sounds.

Troubleshooting:
Check main switch
Check SET/RESUME/CANCEL switch
Check brake pedal position switch and mounting
Check transmission range switch
Check cruise control unit inputs
Check cruise control actuator

Also check for:
Poor ground: G101, G501
Open circuit, loose or disconnected terminals: BLK/YEL, LT GRN, LT GRN/RED, GRY, LT BLU, BLU/WHT, BLK (any of these match the connector that you had disconnected for the ATF drain and fill?)
Cable reel

Fuse #6 (15A) in the Driver’s Under-Dash Fuse/Relay Box also protects: EVAP canister vent shut valve, EVAP bypass solenoid valve, EVAP purge control solenoid valve which could have been related to repair of the P1457 code by the dealer. Has this just happened after this repair was performed?
 
1 - 6 of 6 Posts
Top