Honda Odyssey Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
05 EX 290 k miles

I recently noticed that when I am stopped or very low speed the driver side air vents flow warmer air than the passenger even with sync set and even when I manually adjust the driver side below the passenger. Sitting still the driver side will flow 80 degree air while the passenger side is at 60 or less.

With the rpm up the vents match.

I shut off the ac while parked with the temps still set and vent fan running and the driver side went over 100 degrees. ??? Seems like an air mix control or valve is malfunctioning???

Anyone have experience with this.
 

·
Registered
Joined
·
16 Posts
Mixer control under the driver side dash. Had the exact same with our 09. A couple times unplugging and then plugging it back in worked to reset it. That eventually stopped working though. Then removed the controller, opened and cleaned all the contacts and haven't had an issue since. Think I found a video on YouTube or somewhere on how to do the job. Seems like I recall a replacement being fairly expensive.

Sent from my Pixel using Tapatalk
 

·
Registered
Joined
·
56 Posts
I had a similar issue but in my case the passenger side temp was always higher, no mater what the speed.
Turned out to be low refrigerant at the end...

Sent from my Redmi Note 4 using Tapatalk
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
I took a position indicator out and cleaned the contacts, circular carbon tracks in box, a couple of years ago and returned the new part I had in hand. Right side of driver foot well, PIA to get to. But it was not giving split vent temps.
Coolant seems ok will max down to 40 degrees.
If you remember the search you used to find You Tube please send it.
Thank you
Charles
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
I did find a video I previously watched. And the part is also a drive servo. Looks like another PIA change project:( OR a lawn mower throttle cable and go manual (not)
 

·
Registered
Joined
·
399 Posts
Need to do this on my car as well.... noticed it a few days ago.
 

·
Registered
Joined
·
16 Posts
I took a position indicator out and cleaned the contacts, circular carbon tracks in box, a couple of years ago and returned the new part I had in hand. Right side of driver foot well, PIA to get to. But it was not giving split vent temps.
Coolant seems ok will max down to 40 degrees.
If you remember the search you used to find You Tube please send it.
Thank you
Charles
Think this was it.

Sent from my Pixel using Tapatalk
 
1 - 7 of 7 Posts
Top