Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I recently purchased a very clean and appears to have been well maintained 2008 Odyssey EX-L. We just took her on a approx 1800 mile roundtrip to Florida. Other than the test drive and my wifes around town driving for the past couple of weeks since we got her, this was our first long distance trip. The van has 95,000 miles on it, the original (1 owner) stated she had always had in serviced and by looking at this condition i would agree. The issue that I have noticed is when the "ECO" light comes on, or off, there seems to be a little hesitation, like the transmission is slipping. Of course this could be the fact the engine is getting more or less fuel to the cylinders, just seems a bit rough to me. Almost feels like the transmission mount could be worn. Of course the passnegers did not notice this issue, but I certainly did. Does anyone have any thoughts? Is this normal? Thanks in advance for your input!!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the quick reply. This is my first Honda and just wanted to make sure she was ok. Sounds like this is an ongoing battle with these things, if thats the case i won't worry about fixing !!!
 

·
Registered
Joined
·
19 Posts
I recently purchased a very clean and appears to have been well maintained 2008 Odyssey EX-L. We just took her on a approx 1800 mile roundtrip to Florida. Other than the test drive and my wifes around town driving for the past couple of weeks since we got her, this was our first long distance trip. The van has 95,000 miles on it, the original (1 owner) stated she had always had in serviced and by looking at this condition i would agree. The issue that I have noticed is when the "ECO" light comes on, or off, there seems to be a little hesitation, like the transmission is slipping. Of course this could be the fact the engine is getting more or less fuel to the cylinders, just seems a bit rough to me. Almost feels like the transmission mount could be worn. Of course the passnegers did not notice this issue, but I certainly did. Does anyone have any thoughts? Is this normal? Thanks in advance for your input!!
Did you notice the "slipping" at normal highway speeds or less than 50 mph. If over 50 mph, then read here and let me know if this is what you were feeling - http://www.odyclub.com/forums/52-2005-2010-odyssey/148500-do-you-have-transmission-problem-not-judder-shudder-hard-shifting.html

I call it a "thud", some call it "puddling" as you feel that slight hesitation when going fast through a puddle. The ECO light (I call it VooDoo light) can be misleading. Don't remember if EX's have instant mpg meters, but look at that while you are driving and if you get the "slip" and the mpg meter drops down to 14 is mpg, then you might have what I'm trying to diagnose.
 
1 - 4 of 4 Posts
Top