Honda Odyssey Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Ok I have a friend whose '01 ody has started to have an erratic idle issue. It has the symptoms of the IAC problem with the idle surging in park and neutral between 1k and 2k. What puzzles me is that there is also a extremely late downshift from 2nd to 1st when coming to a stop as well as what seems like a fuel shortage after 3k. The car also has an extremely strong rotten egg smell after driving around that is new which makes me think it could be a cat problem. What do you guys think?

I'm guessing it is a IAC, MAF, or cat problem.
 

·
Registered
Joined
·
665 Posts
I'd bet its an EGR and a IAC problem combined.

Remove the intake manifold with the throttle body on it. Clear out the egr port by hand with a drill bit or even a hex tool. Then force it out into the intake manifold with compressed air. Then, pull the IAC off the throttle body and find some way to clean it out. Many get the bit, take it apart and clean it out. Some use a cleaner and q tips.

Should take you about 2 hours.
 

·
Registered
Joined
·
16 Posts
I have the same problem, but i am spitting misfire codes and a P0340 code for no output from CMP sensor.
 

·
Registered
Joined
·
16 Posts
On that note, I cannot find any reference in the factory service manual for the CMP sensor. Does anyone know where it is located?
 

·
Registered
Joined
·
3,163 Posts
The manual does not list a CMP code nor a P0340 code for the 99 model. It is only for the 03-04 model year.
Anyway this is the information for the 03-04 models. If you have the OEM service manual replacement procedure is in the cylander head section on page 6-60 in the 99-04 manual. It is behind the camshaft pulley that the timing belt rides on.
 

·
Registered
Joined
·
16 Posts
I am getting P0340 code along with multiple cylinder misses. if the code is not for the cam sensor then what is it? Also it hits a rev limiter at 3k. will not go above 3k, in gear or not. BTW, my manual is 1999 only.
 

·
Registered
Joined
·
6,077 Posts
Troubleshoot the following DTCs first if any of them were stored along with the random misfire DTC(s):
P0107, P0108, P1128, P1129: Manifold Absolute Pressure (MAP) Sensor
P0131, P0132: Primary Heated Oxygen Sensor (Primary HO2S)
P0171, P0172: Fuel System
P0335, P0336: Crankshaft Position (CKP) Sensor
P0340, P0341, P0365, P0366: Camshaft Position (CMP) Sensor A/B (’03-04 models)
P0401, P1491, P1498: Exhaust Gas Recirculation (EGR) System
P0505: Idle Control System
P1259: VTEC System
P1361, P1362, P1366, P1367: Top Dead Center (TDC) 1/Top Dead Center (TDC) 2 Sensor (’99-02 models)
P1519: Idle Air Control (IAC) Valve


P0340 Camshaft Position (CMP) Sensor A No Signal

To access the CMP sensor you will have to remove the timing belt. Are you due for the timing belt service while you are in there?
 

·
Registered
Joined
·
16 Posts
Any Honda service techs out there? Talked to a local service center, there is no cam position sensor on this engine. He was no help on the code P0340. Says i need to get it hooked to a Honda scanner at $42.50.
 

·
Registered
Joined
·
16 Posts
Well another side to this story, the van is currently running normal. Nothing has been done to it since the last post. Certainly looks like an intermittent problem.
 
1 - 12 of 12 Posts
Top