Honda Odyssey Forum banner

1 - 20 of 61 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
First off, many thanks to Tim at Hondacuraworld.com for giving me the option of returning the kit if it does not work on the 02 model Ody. Needless to say I wll not be returning it because it works on the 02 models. The installation took about three hours and was fairly easy to install. Here are some pics.
 

Attachments

·
Registered
Joined
·
421 Posts
I guess you need to have the navi (and therefore the leather) in order to have this mod... :(
 

·
Registered
Joined
·
38 Posts
Thanks for the pictures. Did you do the installation? I have read through the instructions and it doesnt look too bad but there are always little things like difficulty reaching a screw.

Do you have any special notes related to installation that the instructions missed?
 

·
Registered
Joined
·
616 Posts
Pretty dang cool - I thought the cover was black?

Below are just the attached pictures above - I just got tired of flipping between screens.

BrianB
<hr>
<center>
<a href="http://www.odyclub.com/forums/attachment.php?s=&postid=75811">
<img src="http://www.odyclub.com/forums/attachment.php?s=&postid=75811" alt="" width="480" height="360" border="2" hspace="2" vspace="2"></a>
<a href="http://www.odyclub.com/forums/attachment.php?s=&postid=75812">
<img src="http://www.odyclub.com/forums/attachment.php?s=&postid=75812" alt="" width="480" height="360" border="2" hspace="2" vspace="2"></a>
<a href="http://www.odyclub.com/forums/attachment.php?s=&postid=75810">
<img src="http://www.odyclub.com/forums/attachment.php?s=&postid=75810" alt="" width="480" height="360" border="2" hspace="2" vspace="2"></a>
</center>
 

·
Registered
Joined
·
479 Posts
Ryu said:
And another
Ryu,
Congratulations it looks great. My only question whether you can install camera in place of "H" logo on hatch? Also, do you mind me asking the cost ?
 

·
Registered
Joined
·
153 Posts
Ryu said:
First off, many thanks to Tim at Hondacuraworld.com for giving me the option of returning the kit if it does not work on the 02 model Ody. Needless to say I wll not be returning it because it works on the 02 models. The installation took about three hours and was fairly easy to install. Here are some pics.
I would be interested in finding out what was in the kit and how much the kit cost. Did it include everything needed (except the monitor)? I could not find such a kit on Tim's website, is there a URL you can refer me to?

Thanks in advance!
GT
 

·
Registered
Joined
·
63 Posts
Discussion Starter #9
Thanls BrianB for posting the pictures. The instruction was very thorough and I didn't experience anything out of the ordinary. The only advice I may have to pass on is to not leave too much slack in the cable behind the camera. The cables connecting the camera will barely reach the mdule behind the side panel. I never crossed my mind to mount the camera in place of the logo. I think the logo is wider than the camera housing. Tim doesn't have the kit listed on his site but he can get it. The price of the kit is $488.40 and free shipping although he FedEx my kit to me :)
 

·
Registered
Joined
·
479 Posts
Ryu said:
Thanls BrianB for posting the pictures. The instruction was very thorough and I didn't experience anything out of the ordinary. The only advice I may have to pass on is to not leave too much slack in the cable behind the camera. The cables connecting the camera will barely reach the mdule behind the side panel. I never crossed my mind to mount the camera in place of the logo. I think the logo is wider than the camera housing. Tim doesn't have the kit listed on his site but he can get it. The price of the kit is $488.40 and free shipping although he FedEx my kit to me :)
The logo is attached with adhesive, although there are 2 small holes behind it---behind the thicker portion of the letter H itself. It looks like the camera housing is plenty big enough to cover holes underneath. Why is it a problem to have too much slack?
 

·
Registered
Joined
·
63 Posts
Discussion Starter #11
voyager said:
Why is it a problem to have too much slack?
The wire is just long enough to reach the module in the side panel. Leaving slacks during the run from the camera to the module is going to result in not the cable not long enough to reach the module.
 

·
Registered
Joined
·
3 Posts
Looks really good! How much did you have to cut to mount the camera? And the black areas on the screen are they shadows or something? How do you toggle between back up screen to Nav? Lastly could it work on my '00 Ody w/ Nav? Sorry for all the questions but I'm pretty eager to order one.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #15
Allan Ariate said:
Looks really good! How much did you have to cut to mount the camera? And the black areas on the screen are they shadows or something? How do you toggle between back up screen to Nav? Lastly could it work on my '00 Ody w/ Nav? Sorry for all the questions but I'm pretty eager to order one.
There was no cutting required. The installation required drilling three 8 mm and one 10 mm hole. The black area on the screen is shadow as I had to pull it into the garage so there wouldn't be any glare on the monitor for the picture. The camera comes on when the tranmission is in reverse. I don't if know it will work on a '00 Ody. The only connection require is the 24-pin connector behind and to the left of the pocket in the center of your dash. If you have this connector chances are pretty good unless the pin-out on it is different.
 

·
Registered
Joined
·
415 Posts
Always trying to be different...

Would the camera mount under the license plate and still have a good rear view? How far out does the camera protrude from the back to front top edge inch-wise?
 

·
Registered
Joined
·
63 Posts
Discussion Starter #19
The housing protrudes out 2 inches from where it meets the vehicle. This kit is an OEM kit sold by Honda for the '03 Ody. There is no splicing of any wires for the installation. It connects to the navi via the 24-pin connector behind the pocket of the lower center console.
 

·
Registered
Joined
·
82 Posts
Looks great!!! Any thought on it working on a 2000 model? Anybody know the difference in Nav units?
 
1 - 20 of 61 Posts
Top