Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 1995 Ody. Replaced a bad ECM unit, now runs OK without stalling. All seems fine, except the the flashing D light comes on when driving. And there is no speedometer/odometer function. After awhile, the check engine light comes on. Still drives fine.

Is there a reset that I need to do after installing the new ECM ? Speedo worked fine before the I replaced the ECM, it just stalls sometimes (bad ECM). How do I go about this ? This is an OBD1, I believe. And where is this connection and what does it look like? I know what an OBD2 connector looks like. Please advise.:)
 

·
Registered
Joined
·
99 Posts
Speed sensor is either bad or disconnected. Speed sensor is on top of the transmission near the firewall. You should remove the air intake piping and look down from where the throttle body is and you'll see a sensor with a three wires sticking straight up from the transmission. That will be the speed sensor.
 

·
Registered
Joined
·
947 Posts
I just wanted to add that I recently experienced my speedometer/odometer quitting along with the flashing D light. Thanks to Overboosten I was able to order a $10 Vehicle Speed Sensor (VSS) off of Ebay and it took me about 20 minutes to replace it. Two days later and everything is working as it should. If you have this problem do not purchase one from Honda or the local auto stores as they charge over $100 for the part. Here is a great video from Youtube on how to replace the VSS and it is on a 95 Ody:
 
1 - 4 of 4 Posts
Top