Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
582 Posts
Discussion Starter #1
I have a question for those w/ the chilton's re: the front bumper.
I let my wife take the odyssey to the hospital today for our twins 1year physical.
She came home and told me that she scraped the front underspoiler. (I have a full VSpec bodykit on, for those that don't understand).
I went out to take a look and it looks like the front bumper came off of the pins on the left side, so there is a little space between the headlight and the bumper. There's a couple of pins under the headlights that I think the bumper hooks on to. I tried to coax the bumper back in/on, but couldn't. How hard is it, to get to those bumper pins. What do I need to take off in order to get to it. It looks like once I'm there, all I have to do is to 'hook' the bumper back onto the pins.
Thanks
 

·
Registered
Joined
·
276 Posts
The bumper cover is held by 2 bolts, 4 clips on the bottom side and 1 screw at each end in the fenderwell.
You need to remove the 4 clips, 1 bolt and the left screw then you should be able to realign the bumper cover with the hooks and push it in. You don't need to remove the whole bumper cover.
Reinstall the bolt, screw and clips and it'll be good as new.

Hope this help.

-Harry
 

·
Registered
Joined
·
582 Posts
Discussion Starter #3
problem is....I can't get to the 4 clips on the bottom. My underspoiler covers them.

Is there any way I can just get in from the top and realign the two holes. They are right under the left front headlight. I can see them, and can actully push the bumper in, but it pops right out.
Can I remove the grill and front headlight and then pop the bumper cover back in place?
 

·
Registered
Joined
·
276 Posts
In order to remove the headlights, you need to remove the bumper cover, so that won't work.

Try to remove the screw that hold the side of the bumper cover and if you can, the bolt at the bottom and see if you can pull the bumper cover outward enough so that you can reach the hooks with a pair of needle nose plier.
What happened to yours is that the hooks' gap became too large to hold the bumper cover, all you need to do is to crimp the hooks to proper gap.

If that don't work, you may need to remove the splash shield where the 4 clips attach to.

-Harry
 
1 - 4 of 4 Posts
Top