Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2002 EXL-nav and today the front heater stopped blowing. It had been making a growling noise and then just quit altogether. When I switch fan speeds I can hear a "click" down under the glove box by the blower motor but no air blows, regardless of fan speed.

Any help would be great. Thank you so much.
 

·
Registered
Joined
·
6,076 Posts
May be a faulty blower motor. Could be a faulty transistor if you have some speeds and not others on the fan speed dial also.

Search on blower motor and transistor.
 

·
Registered
Joined
·
608 Posts
Sounds to me like the bearing on the fan failed or some foreign object made it's way into the blower fins. You should be able to take the cabin filter out or access the blower through that passage way and physically spin the blades. If there is something stuck in it or the bearing seized it won't turn.
Unlikely it's the speed resistor if you have NO fan even on high and it was growling.
 

·
Registered
Joined
·
1,441 Posts
If the power transistor (attached to the heat sink) fails, then the whole AC system, including fan, stops working by design. The "transistor" is a $60 part from Majestic or other mail order and you can replace it in about 10 minutes up under the passenger dash -- it is held in place by three screws. There is a monster thread on this.

However, if the motor was making noise, then it sounds like the motor has failed. I haven't looked at my Helm lately, but I think you can drop the motor out the bottom of the passenger dash and replace it. You may have also blown a fuse. Search on this.
 
1 - 4 of 4 Posts
Top