Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hi all,


I got a quite odd issue from my 03 (228kkm) today..

Approaching a stop sign, when the speed dropped bellow 20km/h, I felt very hard stroke from the front end and the whole vehicle body shuddered severely.. actually it felt like a car behind me hit my rear bumper quite hard (certainly there was no one at my back).
I dropped the gear selector to D2 just in case after she stopped completely and then she kept going like nothing had happened :confused:

Has been driven her for the entire day without any issue since then (not to count 1 slip from 3rd to 2nd which happens from time to time; I almost get used to it :mad: ). No engine light, no TSC light, no blinking 'D', nothing on the dash :confused:

The first thought came up to my mind was a dead trany. But it worked like a charm after (except for one slip).

The second thought is worn engine mounts. But I don't feel any regular shudder from her when idling on traffic lights.


What do you guys think?
Will appreciate any thought :)
 

·
Registered
Joined
·
8,300 Posts
The severe shift you described often precedes transmission failure. But until, and unless, it throws a code, there's not much you can do. How is the fluid level and condition?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4 (Edited)
Thanks guys!

I did hope it's not a trany but looks like quite likely it is :(

Anyway, I had ordered AB solenoids from Bernardy 3 days ago attempting to fix the slip. Will see if it'll make any difference to this crash sound too. Also will check mounts for leak.

PS: ATF was changed 2 weeks ago. Old one and current look and smell good. Level is also fine.
 
1 - 4 of 4 Posts
Top