Honda Odyssey Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hey all,

I have a 2007 honda odyssey ex. Please forgive me if some of this doesn't make sense. Still learning how all this works.

THE CHECK ENGINE LIGHT does NOT turn on for any of this. My headlights flicker, as well as my VSA light on the dash. The battery light comes on occasionally. Sometimes I lose power when accelerating, and the car shakes hard once as if shifting into another gear roughly. This doesn't happen every time I drive it, and it sometimes is just one or two of the symptoms. Eventually the battery drains completely and I can't turn the car on.Things have been getting worse. My power doors don't work anymore, and the headlights work, but the brights won't turn on. Additionally, my radio system doesn't seem to be working either.

All the issues happen intermittently with the exception of the doors and the brights and the radio not working.

I was told to look for a loose or corroded ground.

I had the battery and the alt checked -- Both good.
I replaced the serpentine belt because it was missing a chunk.
I have looked for loose or corroded grounds and have found none (maybe I missed one? Can't find a diagram).
I have checked a few fuses that I thought may be applicable, but I was told it's probably not a fuse issue.

What I can figure is that the battery is getting a charge intermittently. The alternator works (had it bench tested), but for some reason the van is trying to run off of the battery instead of the alternator. I figured this out because one day I left the house, and I didn't drive further than the end of our street and the van wouldn't accelerate anymore. My wife was behind me in my car. I had her pull up and I jumped the van. It turned on, but I didn't make it more than 10 ft before I lost power again. I jumped it again, and the same thing happened, but this time I couldn't go in reverse to turn around and go home. I jumped it one more time, but allowed it to charge longer. this time I had enough power to go in reverse, then to put it back and drive and go back home. I tested the battery while an idle after I had fully charged it. It maintained a reading of 14+ volts, but would occasionally slowly drain, and then sometimes charge.


I've always been able to change brakes, oil, motor mounts, etc.... It wasn't until I had to try and fix this van that I actually started to learn how vehicles work. So I'm still new to all of this, but I'm capable. Please help. Got a wife and kids, and I really need to fix this van so that my wife has a reliable ride.

Thanks
 

·
Super Moderator
Joined
·
13,843 Posts
I would try an alternator swap. While its testing good, since you say charging is intermittent, the alternator may be the issue.

The next issue would be parasitic battery drain most likely due to door micro-switches. Look up threads here on that on how to diagnose as there are dozens of them for the door switches.
 

·
Registered
Joined
·
3,232 Posts
I agree that you probably need a new alternator. Get a Denso - nothing else.

Battery drain could also be caused by a bad AC clutch relay.
 

·
Registered
Joined
·
4 Posts
How old is the alternator? Likes others said, I'd replace with Denso and hopefully it will cure your issue.
 

·
Registered
Joined
·
449 Posts
Most likely its the alternator. If you have the torq app and device, you can set it up to monitor and LOG the battery voltage. Download the log file and review. What you will probably see is intermittent charge from the alt. Replace with Denso reman from rockauto. Any history with the existing alternator being replaced before? Non Denso alts have issues.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #8 ·
Sorry for the late reply....... IT WORKED!! I replaced the alternator and it fixed it. Thanks y'all! Would never have thought to replace an alternator that bench tested good.
 

·
Registered
Joined
·
152 Posts
Trust me it happens all the time. Honda told me that our alternator was fine one time and our starter was fine one time and it wasn't. I replaced and perfect each time
 

·
Registered
2006 Honda Odyssey (EX)
Joined
·
1,300 Posts
The magical powers of Denso...
 

·
Registered
Joined
·
1,000 Posts
159197
 
1 - 11 of 11 Posts
Top