Honda Odyssey Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2007 EX-L that's been producing a very pronounced metallic rattling/buzzing noise only once the engine reaches 2000 RPM. Above and below this point, the noise does not occur. In addition, the noise is only present when the car is in drive. If in park or neutral and revved to 2000 RPM, there is no noise.

It appears to be coming from the engine bay area, possibly more towards the driver side. I initially thought it may be a loose heat shield and had it looked at by a couple local shops and they can't seem to locate the source. The both checked the exhaust heat shields and found there weren't loose. Any suggestions what it could be? Are there any heat shields that are hidden or not obviously found that should be checked?

A sample clip of the noise can be found at the link below.

Dropbox - Memo.m4a - Simplify your life
 

·
Registered
Joined
·
92 Posts
Bump !! I hear the exact same noise, I just started hearing it since this past Thursday after I changed my thermostat and drain and flushed my coolant system. I hear the same rattling at about the rpm .. The speed itself is in and around 20 mph , more or less.. Any help or insight into this problem.
 

·
Registered
Joined
·
28 Posts
This noise happened to me last year. It was, in fact, the heat shields around in the front of the engine. Replacement shields are cheap....the labor to replace them that jacked the price to fix them into the hundreds. Apparently, in order to properly replace these shields, the entire front end of the van comes apart. What I had the tech do was to put steel hose clamps around the shields. Granted, it's just a temporary band-aid, but it worked. I plan on having the shields replaced when the van goes in for the scheduled timing belt replacement.
 

·
Registered
Joined
·
92 Posts
Thanks for the reply .. since I didn't start hearing this noise until the thermostat swap I'm going to tell me tech to see what he did ... see what happens ...

Sent from my SGH-T989 using AutoGuide.com App
 

·
Registered
Joined
·
15 Posts
I have a 2007 EX-L that's been producing a very pronounced metallic rattling/buzzing noise only once the engine reaches 2000 RPM. Above and below this point, the noise does not occur. In addition, the noise is only present when the car is in drive. If in park or neutral and revved to 2000 RPM, there is no noise.
Bumping this old thread. I have a similar problem on my 2010 Odyssey, except that it's around 2200 RPM.

catback (or others), did it end up being the heatshield just as tdogg74 mentioned?
 

·
Registered
Joined
·
788 Posts
Well, it could of course be many things but I've had a similar problem and have had giant hose clamps around my cat heat shields for years now. Problem solved, and cheaply.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
It was the heat shield around the cat for me. I had some metal bands installed around it so it could be tightened up a bit. Haven't heard anything since then.



Bumping this old thread. I have a similar problem on my 2010 Odyssey, except that it's around 2200 RPM.

catback (or others), did it end up being the heatshield just as tdogg74 mentioned?
 

·
Registered
Joined
·
25 Posts
I am experiencing the same issue on my 2010 SE. Started a few weeks ago. Noise / Rattle / Vibration goes away with a shot of gas but come back as the RPMs come back down.

My noise is most prevalent when the engine comes under load, like going up a grade or similar
 

·
Registered
Joined
·
92 Posts
I am experiencing the same issue on my 2010 SE. Started a few weeks ago. Noise / Rattle / Vibration goes away with a shot of gas but come back as the RPMs come back down.

My noise is most prevalent when the engine comes under load, like going up a grade or similar
check the heat shields around the headers (right before the flex pipe) thats where my rattling was coming from. i took it to my local exhaust shop and he gave it a couple of quick tack welds and the rattling stop. also check around the heat shields around the cat.
 

·
Registered
Joined
·
6,074 Posts

·
Registered
Joined
·
11 Posts
I know this is an old thread but does anyone have a picture of the hose clamps around the CAT heat shields that fixed the issue? I'm trying ton imagine how that would help and my imagination isn't that great I guess.
 
1 - 12 of 12 Posts
Top