Honda Odyssey Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter #1
Today my nav system would respond very very slowly. It took forever to enter Montgomery(sp?) as the city. The letter would change colors as you touched it, but I'd drive a mile or so before it would show up in the city field. Later, when I finally got the destination entered, the gps was about a mile or more behind me! It is a 2001 Ody, so maybe it is about time. Sometimes it gets confused and I have to pound on the dash, but that is probably a loose connection.... Any ideas?
 

·
Registered
Joined
·
3,163 Posts
Clean the CD and get a drive cleaning disk and clean the drive. Just use dish washing liquid to mildly clean the disk. It is slow because it is probably getting a lot of read errors.
 

·
Registered
Joined
·
214 Posts
Discussion Starter #3
Today I got a message when I started the car that said it was very cold and startup would take a while. I thought about cleaning the CD but would that have anything to do with the GPS indicating the wrong position? I'll try cleaning it....
 

·
Registered
Joined
·
214 Posts
Discussion Starter #4
Thanks William. The DVD was definitely dirty. Cleaning it made a world of difference.
 

·
Registered
Joined
·
3,163 Posts
Unfortunately the Honda GPS does not store the GPS maps in memory. It reads thenm from the DVD. So when you get read errors it takse some time to generate the location.

Also when it gets really cold it takes time for the motors to spin up and sometimes for the display to brighten up.
 
1 - 5 of 5 Posts
Top