Honda Odyssey Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Ok so I have a 2005 I have misfire codes. Every time I park the van for a little while when I go to start it it misfires worse then if not sitting long. When I start it first thing in the morning is the worst also flashing CEL once it runs for a min it stops flashing. First codes are always P0300 P0306 &P0305. Occasionally the other 3 will come but not all the time very rare I get a P0420. So far I’ve adjusted the valves, fuel cleaner, changed the plugs rotated all of the coils, ran compression check and cleaned EGR. Compression check was good. I pulled the O2 on the front closest to radiator and seen a few pieces of the mesh laying on top. Any thoughts on what could be going on? Here is pic of front cat closest to radiator.
 

Attachments

·
Registered
Joined
·
12,145 Posts
Any smoke when the van first starts and is running rough? If so, what color? White smoke indicates coolant burning and blue smoke indicates oil burning. Black smoke indicates a rough mixture. What I do when troubleshooting this is look for any smoke. If that doesn't give me a clue, then I start it cold, and shut it off while it's running rough. Then pull the plugs and have a look at them. They will likely tell the story of what's going on.
 

·
Registered
Joined
·
62 Posts
Ok so I have a 2005 I have misfire codes. Every time I park the van for a little while when I go to start it it misfires worse then if not sitting long. When I start it first thing in the morning is the worst also flashing CEL once it runs for a min it stops flashing. First codes are always P0300 P0306 &P0305. Occasionally the other 3 will come but not all the time very rare I get a P0420. So far I’ve adjusted the valves, fuel cleaner, changed the plugs rotated all of the coils, ran compression check and cleaned EGR. Compression check was good. I pulled the O2 on the front closest to radiator and seen a few pieces of the mesh laying on top. Any thoughts on what could be going on? Here is pic of front cat closest to radiator.
I had similar issues at ~190xxx. What helped me is changing valve cover gaskets (but did not remove completely) and then the PCV valve. Then the misfires gone.
 

·
Registered
Joined
·
844 Posts
If it idles rough, you should do a coil drop test and identify which cylinder has the misfire. Could be coil (usual), spark plug (pull and inspect) or fuel causing your misfire.
Plenty of posts here and u-toob videos to show how to do a coil drop test.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #9
Ok so I have update with new problem......I was noticing a very light white smoke. I also have been having to add very little coolant every so often with no leak found anywhere. Also radiator cap under vacuum when removing cold. looked up a video on head gasket leaks and they said all those symptoms and to check radiator cap for heat Deterioration and sure enough I have it. So at this point I’m thinking I have a very fine coolant leak from head gasket to cylinder. I read online that Blue Devil pour and go is the best so I bought a bottle. 2 days later I have NO rough idle at first startup and NO flashing CEL heck NO CEL at all TILL this morning. Checked CEL and now I’m getting P0430 and P0420 But no more misfire codes
 
1 - 9 of 9 Posts
Top