Honda Odyssey Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
1. My van seems to, when braking grab hard sometimes. Also when braking it seems as it slows down at certain points the rpms jump, like the transmission is down shifting.
2. Seems that it drops a little hard into the last gear. Just not smooth. My mechanic has checked the transmission codes and it is all good he says.

Any help would be great. Thanks
 

·
Registered
Joined
·
22 Posts
I just got a 2005 Touring as well and sounds as you are experiencing some of the same feelngsI have...

1. I just Did my Brakes... The ones on there were like new... but I could tell the rotor they used when doing that job was the bare min...so I replaced rotor and pads...

I for sure had a warped rotor as now I do not get the "Bite Drag" of the pads when stopping.

2. As for as Tranny, Maybe check your fluid...My dealer flushed mine as it is a perfect color... check your and swap if necessary.. that should solve the hard shift issue..

Or maybe you have a TorqueConv issue?

3. You may also have a Motor mount issue... Hard to say at this point till others (and easier) things solved first.

However once some of these are cleared up... smooth driving bliss awaits..
 

·
Registered
Joined
·
174 Posts
I have an 05 also, and, yes, the downshifting while slowly braking takes a little getting used to. It was more pronounced when my transmission was due for a drain and fill, afterwards it's much smoother, but still utilizes "gear braking" while slowing to a stop. (Transmission downshifts to slow the vehicle as opposed to using the brakes exclusively.)
 

·
Registered
Joined
·
583 Posts
We have an 05 too and at first it was downshifing very roughly for the first 40-50k miles. And all of the sudden it mysteriously stopped and then the trans judder started to happened which was then fixed by a new rear engine mount. It's been smooth since and still is at 105k now.
 
1 - 4 of 4 Posts
Top